Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#50694 - [linux] Kernel 4.7 causes boot time increase due to ACPI EC

Attached to Project: Arch Linux
Opened by John Henderson (jwhendy) - Wednesday, 07 September 2016, 14:07 GMT
Last edited by Jan de Groot (JGC) - Wednesday, 04 October 2017, 03:28 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

After upgrading to kernel 4.7, my boot time went from ~13sec to 24sec. I posted around and didn't get much response, so I created a kernel bug report:
- https://bugzilla.kernel.org/show_bug.cgi?id=153511

Here was Lv Zheng's summary of the issue:

###
This is in fact not an issue.
Just because _REG (which consumes time on this platform) is executed more times than the previous version.
However it really can be tuned not to execute so many times by checking if 2 EC devices are equivelent.
###

Additional info:
* package: core/linux (at 4.7.2-1 as of 2016-09-06)

LTS vs. 4.7.0 (which is what I was on at the time):

## kernel 4.4.16
$ systemd-analyze
Startup finished in 4.683s (kernel) + 7.625s (initrd) + 1.084s (userspace) = 13.393s

### kernel 4.7.0
$ systemd-analyze
Startup finished in 10.746s (kernel) + 10.518s (initrd) + 4.060s (userspace) = 25.325s

Bug report: https://bugzilla.kernel.org/show_bug.cgi?id=153511


Steps to reproduce:
- boot system as usual on 4.7 vs. 4.6 or LTS.

The bug report resulted in a patch that has me back to just over 14sec, so I considered the issue solved. They say the fix won't be implemented until 4.9, so I thought I'd pass along the info here in the event we'd want to include this in the Arch patchset. I'm not sure how those decisions get made, but it'd be awesome not to have to compile my own with every update!

This is the patch that worked on 4.7.2 compiled via ABS: https://bugzilla.kernel.org/attachment.cgi?id=232071
This task depends upon

Closed by  Jan de Groot (JGC)
Wednesday, 04 October 2017, 03:28 GMT
Reason for closing:  Fixed

Loading...