Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#50684 - [opencascade] Patch for opencasade 6.9.1

Attached to Project: Arch Linux
Opened by Michele Mocciola (mickele) - Wednesday, 07 September 2016, 02:34 GMT
Last edited by Florian Pritz (bluewind) - Wednesday, 05 October 2016, 22:46 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Florian Pritz (bluewind)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
At http://files.salome-platform.org/Salome/other/patches/OCCT-6.9.1.patch, salome developer have added some patch to release 6.9.1 of opencascade. These page add a new method and solve e bug (see page 13 at http://files.salome-platform.org/Salome/Salome7.8.0/SALOME_7_8_0_Release_Notes.pdf for more info on the patch).

Additional info:
* opencascade 6.9.1

This task depends upon

Closed by  Florian Pritz (bluewind)
Wednesday, 05 October 2016, 22:46 GMT
Reason for closing:  Implemented
Comment by Florian Pritz (bluewind) - Friday, 09 September 2016, 07:34 GMT
The patch seems rather extensive, I have no way of testing it and I don't want to have to maintain it in the future. If it has been merged by opencascade upstream for 7.0 I might apply it, but if it is only a third party patch I will not. Can you check if it has been merged upstream?
Comment by Michele Mocciola (mickele) - Friday, 09 September 2016, 10:53 GMT
It isn't a third part patch, salome and opencascade developers are strictly bind.
I confirm that patch ha already been merged in 7.0.0 version.
Comment by Florian Pritz (bluewind) - Tuesday, 13 September 2016, 15:06 GMT
I've released opencascade 6.9.1-3 to [community-testing]. Please check if it works for you.
Comment by Michele Mocciola (mickele) - Tuesday, 13 September 2016, 18:26 GMT
It's ok for me.
Comment by Florian Pritz (bluewind) - Tuesday, 20 September 2016, 19:29 GMT
Since this breaks freecad (see  FS#50829 ) even though I rebuilt it, I'm pulling it back out. I'm afraid you'll have to wait for opencascade 7.0.0 or patch it yourself.
Comment by Florian Pritz (bluewind) - Friday, 23 September 2016, 12:31 GMT
Turns out this patch isn't the cause of the problem. It is actually a change in gcc that optimizes away some checks. The patch will continue to be in the package for now until it really leads to problems. I'm also keeping this report open for a week or two so I don't have to reopen it all the time.

Loading...