FS#50681 - [networkmanager] Update from 1.2.5 to 1.4.1 breaks wifi - probably NFS problem

Attached to Project: Arch Linux
Opened by Stefan Förster (HotblackDesiato) - Tuesday, 06 September 2016, 22:17 GMT
Last edited by Andreas Radke (AndyRTR) - Sunday, 27 February 2022, 08:47 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No



I updated NetworkManager one day ago on my desktop (x86_64) and my notebook (IBM ThinkPad X41, x86). On both machines connection to my hotspot failed subsequently. I downgraded to 1.2.5 and wifi worked again.

I believe that it is a NFS problems. In order to start xfce4 properly w/o network connection, I deactivated the fstab entry for my NFS shares on the desktop. I mount an NFS share at reboot on both computers. After reboot the NetworkManager 1.4.1 was able to connect to the hotspot on the desktop.

Steps to reproduce:
1) mount NFS share during boot (mount entry in fstab)
2) upgrade networkmanager to 1.4.1
3) reboot
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Sunday, 27 February 2022, 08:47 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed upstream.
Comment by Doug Newgard (Scimmia) - Thursday, 08 September 2016, 14:05 GMT
Always include specific package versions. We have 3 different 1.4.1's that have been in the repos.
Comment by Stefan Förster (HotblackDesiato) - Saturday, 10 September 2016, 02:50 GMT
The version is 1.4.1dev+33+gc87b89b-1
Comment by Stefan Förster (HotblackDesiato) - Saturday, 10 September 2016, 03:35 GMT
You can close this task, I have found the cause. It was my custom NetworkManager.service file that persisted after the update to 1.4.1 and seems to be incompatible with the new version. This custom file had always been nececessary in order to get a clean shutdown when my NFS share is mounted (and I had protected it with 'chattr +i' to prevent it from being overwritten with every update). With the new version this is no longer needed, so also this NFS problem seems to be solved.

Sorry for inconvenience.
Comment by Stefan Förster (HotblackDesiato) - Saturday, 10 September 2016, 07:19 GMT
I just updated also my notebook with the latest Network-Manager version incl. the service file. Unfortunately, on my notebook the connection to my hot spot fails, while it works perfectly on my desktop. Please do not close the bug report.
Comment by Jan Alexander Steffens (heftig) - Saturday, 10 September 2016, 09:26 GMT
Try adding the following lines to /etc/NetworkManager/NetworkManager.conf, then reboot:

Comment by Stefan Förster (HotblackDesiato) - Monday, 12 September 2016, 01:25 GMT
@Jan: added the lines, but no change. nm-applet sees my 3 signals (1 x 2.4GHz and 2 x 5GHz) and the neighbours hot spots, but cannot connect. The following error pops up when I choose one of my hot spots:

Aktivierung der Verbindung fehlgeschlagen. [Activation of connetion failed]
(2) Die aktive Verbindung wurde entfernt, bevor sie initialisiert wurde. [The active connection has been removed before she was initialised]
Comment by mattia (nTia89) - Friday, 25 February 2022, 16:09 GMT
Is this issue still valid with latest version of networkmanager?
Comment by Stefan Förster (HotblackDesiato) - Sunday, 27 February 2022, 00:26 GMT
No more issues.