Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#50621 - [kodi] Locks up on certain media key presses

Attached to Project: Community Packages
Opened by Curtis Lee Bolin (curtisleebolin) - Thursday, 01 September 2016, 07:27 GMT
Last edited by Jonathan Roemer (pid1) - Monday, 12 September 2016, 21:25 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Ike Devolder (BlackEagle)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
After running updates on 2016 Aug 23, Kodi locks up on certain keyboard media key presses. Other programs do NOT. Kodi did not upgrade, but linux did "linux (4.6.4-1 -> 4.7.1-1)". I have since upgraded linux to 4.7.2-1 with no change. libevdev (1.5.2-1 -> 1.5.3-1) and libwacom (0.21-1 -> 0.22-1) also upgraded on that same day. I use xf86-input-libinput, but I also uninstalled that and tried xf86-input-evdev with the same issue. I have tried kodi's debug log, but it immediately locks with no debug info added to the log. Not even the key press is shown in the log. I have tried this with 5 different USB keyboards.

List of keys that lock up Kodi:
# libinput-debug-events --device /dev/input/event1
event1 DEVICE_ADDED USB Universal Driver seat0 default group1 cap:kp left scroll-nat scroll-button
event1 KEYBOARD_KEY +4.71s KEY_STOPCD (166) pressed
event1 KEYBOARD_KEY +4.77s KEY_STOPCD (166) released
event1 KEYBOARD_KEY +5.42s KEY_PREVIOUSSONG (165) pressed
event1 KEYBOARD_KEY +5.50s KEY_PREVIOUSSONG (165) released
event1 KEYBOARD_KEY +6.07s KEY_PLAYPAUSE (164) pressed
event1 KEYBOARD_KEY +6.17s KEY_PLAYPAUSE (164) released
event1 KEYBOARD_KEY +6.66s KEY_NEXTSONG (163) pressed
event1 KEYBOARD_KEY +6.74s KEY_NEXTSONG (163) released


Additional info:
* kodi 16.1-4


Steps to reproduce:
Start Kodi. Press stop, previous, next, or play/pause media key on a keyboards. Kodi locks up.
This task depends upon

Closed by  Jonathan Roemer (pid1)
Monday, 12 September 2016, 21:25 GMT
Reason for closing:  Upstream
Additional comments about closing:  Resolved
Comment by Curtis Lee Bolin (curtisleebolin) - Thursday, 01 September 2016, 07:57 GMT
Upstream bug report: http://trac.kodi.tv/ticket/16871

Also I am adding the debug log.
   kodi.log (44.8 KiB)
Comment by Lars Hagström (DonOregano) - Friday, 02 September 2016, 21:22 GMT
Have the same issue, tried downgrading kodi, libevdev, linux-lts and lirc, all of which were upgraded in my latest -Syu. No difference.
Comment by Lars Hagström (DonOregano) - Friday, 02 September 2016, 22:10 GMT
It's the recent dbus change that seems to be causing it. Downgrading dbus like this removes the problem for me:

sudo pacman -U /var/cache/pacman/pkg/dbus-1.10.8-1-x86_64.pkg.tar.xz /var/cache/pacman/pkg/lib32-libdbus-1.10.8-1-x86_64.pkg.tar.xz /var/cache/pacman/pkg/libdbus-1.10.8-1-x86_64.pkg.tar.xz
Comment by Curtis Lee Bolin (curtisleebolin) - Sunday, 04 September 2016, 09:19 GMT
Lars Hagström, I can not confirm because downgrading dbus causes Arch Linux to be unbootable for me.
Comment by Curtis Lee Bolin (curtisleebolin) - Sunday, 04 September 2016, 09:31 GMT
Lars Hagström, after installing dbus-1.10.10 again to get Arch Linux to boot, I downgraded to dbus-1.10.8 with libdbus-1.10.8. Then restarted dbus.socket and dbus.service, and kodi. Kodi starts in a locked up state. Sorry, I still can not confirm, but kodi does seem to be very sensitive to
Comment by Curtis Lee Bolin (curtisleebolin) - Sunday, 04 September 2016, 09:32 GMT
Lars Hagström, after installing dbus-1.10.10 again to get Arch Linux to boot, I downgraded to dbus-1.10.8 with libdbus-1.10.8. Then restarted dbus.socket and dbus.service, and kodi. Kodi starts in a locked up state. Sorry, I still can not confirm, but kodi does seem to be very sensitive to changes in dbus.
Comment by Curtis Lee Bolin (curtisleebolin) - Monday, 12 September 2016, 03:10 GMT

Loading...