Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#50605 - [linux] Screen Pulsates on latest kernel

Attached to Project: Arch Linux
Opened by Kenton (Krutonium) - Wednesday, 31 August 2016, 01:58 GMT
Last edited by Doug Newgard (Scimmia) - Wednesday, 15 November 2017, 23:20 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
On my MSI GP60 2QF Laptop, when running the latest kernel (problem does not appear on LTS kernel) the screen pulsates (See: https://www.youtube.com/watch?v=xGnGDUaLOis) but only when X is running - Before X is installed or running, the screen is visibly fine.

Additional info:
Tell me what to attach and I will do so, I am not sure what is relevant.


Steps to reproduce:
Install Arch, and get a DE running.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Wednesday, 15 November 2017, 23:20 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#49371 
Comment by Giuseppe (G-G) - Wednesday, 31 August 2016, 11:08 GMT
intel HD graphics? There is a common issue with intel Panel Self Refresh (PSR) which cause the screen to flicker since kernel ~4.6, after they enabled that option by default. Try to disable it by adding i915.enable_psr=0 to the kernel command line.

You can also find several related post on the forum, like this one:
https://bbs.archlinux.org/viewtopic.php?id=214032
Comment by Kenton (Krutonium) - Thursday, 01 September 2016, 07:16 GMT
That seems to have worked, thanks!

Loading...