Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#50574 - [libpng12] Missing header files.

Attached to Project: Community Packages
Opened by Llewelyn Trahaearn (llewelyn) - Monday, 29 August 2016, 18:34 GMT
Last edited by Maxime Gauduin (Alucryd) - Tuesday, 30 August 2016, 09:58 GMT
Task Type Feature Request
Category Packages
Status Closed
Assigned To Maxime Gauduin (Alucryd)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description: A user of vsxu-git in the AUR has pointed out the remove statement in the package section of the PKGBUILD seems to be a bit blind and heavy handed, removing not only files that conflict with libpng but core components. At present this package provides only the shared object files necessary for dynamically linked binaries to run. It lacks the necessary header files for users wanting to build applications from source. The lack of these files also makes lib32-libpng12's dependency on this package superfluous as it doesn't provide anything but the licence: a symbolic link to the licence saves little space and will cause utilities like namcap to complain it's missing.

As part of some tests I modified the PKGBUILD to trim out only the files that conflict directly with libpng instead of everything but the .so files. The updated package recipe in total is located here: https://gist.github.com/WoefulDerelict/23ca3183aa9ec0b240589c8cd9439f5c

The remove command in package was made much more specific, eliminating only the conflicting symlinks and manuals. I changed it from: rm -rf "${pkgdir}"/usr/{bin,include,lib/{libpng.{a,so},pkgconfig},share} to: rm -rf "${pkgdir}"/usr/{bin/libpng-config,include/*.h,lib/{libpng.{a,so},pkgconfig/libpng.pc},share}

Additional info:
libpng12-1.2.56-4
This task depends upon

Closed by  Maxime Gauduin (Alucryd)
Tuesday, 30 August 2016, 09:58 GMT
Reason for closing:  Won't implement
Additional comments about closing:  Removed the dep on regular libpng12, but I won't include the headers as it seems pointless
Comment by Doug Newgard (Scimmia) - Tuesday, 30 August 2016, 03:49 GMT
"At present this package provides only the shared object files necessary for dynamically linked binaries to run."

Which is generally the point of old libs in the repos. Why would you ever link against this?
Comment by Maxime Gauduin (Alucryd) - Tuesday, 30 August 2016, 08:55 GMT
With only a few exceptions, this is how we handle old versioned libs. I'm not even sure why that user complains because vsxu-git builds fine against regular libpng, and vsxu should only need a wee bit of patching to behave the same.

Loading...