Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#50561 - [dbus] typing the german letter ß crashes Xorg

Attached to Project: Arch Linux
Opened by sekret (sekret) - Monday, 29 August 2016, 11:03 GMT
Last edited by Doug Newgard (Scimmia) - Tuesday, 30 August 2016, 04:04 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description:
Ever since the update from libdbus to dbus

[2016-08-28 09:02] [ALPM] transaction started
[2016-08-28 09:02] [ALPM] removed libdbus (1.10.8-1)
[2016-08-28 09:02] [ALPM] upgraded dbus (1.10.8-1 -> 1.10.10-3)

or in other words, since the update of dbus from 1.10.8 to 1.10.10, I (and others, see https://bbs.archlinux.de/viewtopic.php?id=29516 ) cannot write the letter ß in a Xorg session, because it crashes Xorg. In fact I have to c&p the letter into this bugreport ;-)

A downgrade seems to solve the problem.

Additional info:
* package version(s)

libdbus 1.10.8 was fine, dbus 1.10.10 causes the problem

* config and/or log files etc.

Xorg.0.log doesn't show anything suspicious

Steps to reproduce:

Start a Xorg session and type ß. Then try to e.g. switch windows etc. You'll only be able to use the last selected window, anything else is gone.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Tuesday, 30 August 2016, 04:04 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Don't use dbus-launch
Comment by sekret (sekret) - Monday, 29 August 2016, 11:04 GMT
Ah crap, this bug report is of course very critical!!! Forgot to adjust that ...
Comment by sekret (sekret) - Monday, 29 August 2016, 12:09 GMT
Ok I managed to "solve" this by editing my ~/.xinitrc and changed

exec dbus-launch --exit-with-session dwm

to

exec dwm
Comment by Henning (Aldus) - Monday, 29 August 2016, 12:40 GMT
On my Dell Latitude D620 (Arch + Xfce4), hitting ß makes the whole Xorg session (except the mouse pointer) freeze. Since ß is indispensable for writing in German, this bug makes the system unusable. As a provisional solution, I had to downgrade to dbus 1.10.8-1. Editing .xinitrc as described by sekret also works.

Loading...