Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#50484 - [lib32-tcl] Do not delete /usr/lib32/libtclstub8.6.a

Attached to Project: Community Packages
Opened by Nikos Theodorou (GordonGR) - Monday, 22 August 2016, 17:00 GMT
Last edited by Maxime Gauduin (Alucryd) - Wednesday, 24 August 2016, 22:52 GMT
Task Type Bug Report
Category Packages: Multilib
Status Closed
Assigned To Maxime Gauduin (Alucryd)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Greetings.

I am the maintainer of aur/lib32-tk[a]. Lately I've been having complaints from users[b] that compiling the package cannot continue, due to an incompatible /usr/lib/libtclstub8.6.a (coming from extra/tcl).

The error seems rational, since lib32-tcl lacks the corresponding libtclstub8.6.a (you delete it in line 44 of your PKGBUILD), however for some reason I am able to compile lib32-tk using the 64bit /usr/lib/libtclstub8.6.a, and the result is 32bit!

At any rate, I would like to kindly ask you to retain /usr/lib32/libtclstub8.6.a in your PKGBUILD, and perhaps the rest of the files in line 44, since they may be useful for compiling lib32-tk.

Thank you.

[a] https://aur.archlinux.org/packages/lib32-tk/
[b] prMoriarty's comment on 2016-08-20 20:07 and Maverick's on 2016-08-22 13:21.
This task depends upon

Closed by  Maxime Gauduin (Alucryd)
Wednesday, 24 August 2016, 22:52 GMT
Reason for closing:  Fixed
Additional comments about closing:  8.6.6-2
Comment by Doug Newgard (Scimmia) - Tuesday, 23 August 2016, 13:31 GMT
Looking at the main tcl package, it keeps static libs.

Loading...