Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#50474 - [libreoffice-still] crashes upon start

Attached to Project: Arch Linux
Opened by sekret (sekret) - Sunday, 21 August 2016, 17:33 GMT
Last edited by Andreas Radke (AndyRTR) - Tuesday, 23 August 2016, 10:11 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

When I try to launch libreoffice, I see this first screen with the big 5 (don't remember what that's called in english, sorry...) and then it crashes. Here's the output when launched in a terminal:

$ libreoffice
terminate called after throwing an instance of 'com::sun::star::uno::DeploymentException'


Fatal exception: Signal 6
Stack:
/usr/lib/libreoffice/program/libuno_sal.so.3(+0x39cd0)[0x7fb8a155dcd0]
/usr/lib/libreoffice/program/libuno_sal.so.3(+0x3a063)[0x7fb8a155e063]
/usr/lib/libreoffice/program/libuno_sal.so.3(+0x3a198)[0x7fb8a155e198]
/usr/lib/libc.so.6(+0x330b0)[0x7fb8a0f270b0]
/usr/lib/libc.so.6(gsignal+0xcf)[0x7fb8a0f2704f]
/usr/lib/libc.so.6(abort+0x16a)[0x7fb8a0f2847a]
/usr/lib/libstdc++.so.6(_ZN9__gnu_cxx27__verbose_terminate_handlerEv+0x16d)[0x7fb8a05d44bd]
/usr/lib/libstdc++.so.6(+0x8f276)[0x7fb8a05d2276]
/usr/lib/libstdc++.so.6(+0x8f2c1)[0x7fb8a05d22c1]
/usr/lib/libstdc++.so.6(+0x8f4d8)[0x7fb8a05d24d8]
/usr/lib/libreoffice/program/libutllo.so(+0x58891)[0x7fb89b8c6891]
/usr/lib/libreoffice/program/libutllo.so(+0x5a04f)[0x7fb89b8c804f]
/usr/lib/libreoffice/program/libutllo.so(+0x5acea)[0x7fb89b8c8cea]
/usr/lib/libreoffice/program/libutllo.so(_ZN3utl10ConfigItemC2ERKN3rtl8OUStringE14ConfigItemMode+0x84)[0x7fb89b8b9594]
/usr/lib/libreoffice/program/libutllo.so(+0xb9051)[0x7fb89b927051]
/usr/lib/libreoffice/program/libutllo.so(_ZN19SvtSysLocaleOptionsC1Ev+0x85)[0x7fb89b927695]
/usr/lib/libreoffice/program/libutllo.so(+0xe0a03)[0x7fb89b94ea03]
/usr/lib/libreoffice/program/libutllo.so(_ZN12SvtSysLocaleC1Ev+0x55)[0x7fb89b94eae5]
/usr/lib/libreoffice/program/libvcllo.so(+0x43309c)[0x7fb89b46909c]
/usr/lib/libreoffice/program/libvcllo.so(_ZN11AllSettingsC1Ev+0x46)[0x7fb89b4691d6]
/usr/lib/libreoffice/program/libvcllo.so(_ZN11Application12InitSettingsEP10ImplSVData+0x1e)[0x7fb89b46fc6e]
/usr/lib/libreoffice/program/libvcllo.so(_ZN11Application11GetSettingsEv+0x2d)[0x7fb89b46fd1d]
/usr/lib/libreoffice/program/libvclplug_gtk3lo.so(+0x3f772)[0x7fb888093772]
/usr/lib/libreoffice/program/libvcllo.so(_Z7InitVCLv+0x292)[0x7fb89b474b12]
/usr/lib/libreoffice/program/libvcllo.so(+0x43f726)[0x7fb89b475726]
/usr/lib/libreoffice/program/libvcllo.so(_Z6SVMainv+0x22)[0x7fb89b475832]
/usr/lib/libreoffice/program/libsofficeapp.so(soffice_main+0xa2)[0x7fb8a12defc2]
/usr/lib/libreoffice/program/soffice.bin[0x4006db]
/usr/lib/libc.so.6(__libc_start_main+0xf1)[0x7fb8a0f14291]
/usr/lib/libreoffice/program/soffice.bin[0x40071a]



Additional info:
* package version(s)

libreoffice-still 5.1.5-2
libreoffice-still-de 5.1.5-1


I don't know if recompiling fixes this, because my laptop is too weak, would take ages, maybe wouldn't compile in the first place.
And I don't know when this started, I rarely use libreoffice.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Tuesday, 23 August 2016, 10:11 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#50289 
Comment by Andreas Radke (AndyRTR) - Sunday, 21 August 2016, 18:19 GMT
You may try to use gtk2 or generic vcl. What graphics driver do you use?
Comment by sekret (sekret) - Sunday, 21 August 2016, 18:25 GMT
I use xf86-video-ati, here's my output of lspci for the video driver:

$ lspci | grep VGA
00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Wrestler [Radeon HD 6320]

How can I use gtk2 or generic vcl? And what is generic vcl?? *schäm*
Comment by Andreas Radke (AndyRTR) - Sunday, 21 August 2016, 18:33 GMT Comment by sekret (sekret) - Sunday, 21 August 2016, 18:57 GMT
Oh I see, thanks for the info!!!

Ok I tested them all:

1. SAL_USE_VCLPLUGIN=gen https://paste.pound-python.org/raw/fYJnYN4NQcE4Pkhvx5Oq
2. SAL_USE_VCLPLUGIN=gtk https://paste.pound-python.org/raw/LxtlqA3SExnZH0ag7tlq
3. SAL_USE_VCLPLUGIN=gtk3 https://paste.pound-python.org/raw/OuqahsPCJQ96laHGZc9c
4. SAL_USE_VCLPLUGIN=kde4 https://paste.pound-python.org/raw/pTL1rJW6LBkGmZkDUYt1

SAL_USE_VCLPLUGIN=kde4 isn't supposed to work, because I don't have the required dependency kdelibs installed. Still it produces basically the same output I get with gtk and gtk3. However SAL_USE_VCLPLUGIN=gen produces a different output.

Maybe this is interesting aswell to see, which optional dependencies I have installed.

$ pacman -Qi libreoffice-still
Name : libreoffice-still
Version : 5.1.5-2
Description : LibreOffice maintenance branch
Architecture : x86_64
URL : http://www.libreoffice.org/
Licenses : LGPL3
Groups : None
Provides : libreoffice libreoffice-en-US
Depends On : curl>=7.20.0 hunspell>=1.2.8 python>=3.5 libwpd>=0.9.2 libwps neon>=0.28.6 pango nspr libjpeg libxrandr libgl dbus-glib libxslt redland icu hyphen lpsolve gcc-libs sh graphite lcms2
poppler>=0.24.0 libvisio libetonyek libodfgen libcdr libmspub harfbuzz-icu glew nss clucene hicolor-icon-theme desktop-file-utils shared-mime-info glu libpagemaker libxinerama libabw libmwaw
libe-book libcups gtk2 liborcus liblangtag libexttextcat libfbclient libcmis
Optional Deps : java-runtime: adds java support [installed]
java-environment: required by extension-wiki-publisher and extension-nlpsolver [installed]
pstoedit: translates PostScript and PDF graphics into other vector formats [installed]
libmythes: for use in thesaurus
beanshell2: interactive java -- good for prototyping/macros
vigra: C++ computer vision library, usable in Basebmp
libmspack: library for Microsoft compression formats for use in FontOOo
libwpg: library for importing and converting WordPerfect Graphics format [installed]
sane: for scanner access [installed]
unixodbc: adds ODBC database support
gst-plugins-base-libs: for multimedia content, e.g. in Impress [installed]
libpaper: takes care of papersize [installed]
postgresql-libs: for postgresql-connector [installed]
coin-or-mp: required by the Calc solver
gtk3: for GTK3 integration [installed]
kdelibs: for KDE desktop integration
Required By : libreoffice-still-de unoconv
Optional For : None
Conflicts With : libreoffice-fresh
Replaces : None
Installed Size : 342.10 MiB
Packager : Andreas Radke <andyrtr@archlinux.org>
Build Date : Wed 03 Aug 2016 07:37:18 PM CEST
Install Date : Tue 09 Aug 2016 08:41:46 PM CEST
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : Signature

Hope this helps!


I'm not entirely sure if I used libreoffice since this current version got released. Maybe I'll give the previous version a try (slow internet here, takes 30 minutes to download, so I'll post the results in the next comment)
Comment by sekret (sekret) - Sunday, 21 August 2016, 20:18 GMT
Ah crap!

$ libreoffice
/usr/lib/libreoffice/program/soffice.bin: error while loading shared libraries: libGLEW.so.1.13: cannot open shared object file: No such file or directory

So the bump in pkgver was a pure rebuild ...



Can anyone confirm this problem? Or am I alone?!
Comment by sekret (sekret) - Sunday, 21 August 2016, 22:25 GMT
Ok, so I installed libreoffice-fresh 5.2.0-2 to see if this problem occurs with it aswell. Yes it does.

$ libreoffice
terminate called after throwing an instance of 'com::sun::star::uno::DeploymentException'


Fatal exception: Signal 6
Stack:
/usr/lib/libreoffice/program/libuno_sal.so.3(+0x39960)[0x7fdc66cdd960]
/usr/lib/libreoffice/program/libuno_sal.so.3(+0x39ad1)[0x7fdc66cddad1]
/usr/lib/libc.so.6(+0x330b0)[0x7fdc6669b0b0]
/usr/lib/libc.so.6(gsignal+0xcf)[0x7fdc6669b04f]
/usr/lib/libc.so.6(abort+0x16a)[0x7fdc6669c47a]
/usr/lib/libstdc++.so.6(_ZN9__gnu_cxx27__verbose_terminate_handlerEv+0x16d)[0x7fdc65d484bd]
/usr/lib/libstdc++.so.6(+0x8f276)[0x7fdc65d46276]
/usr/lib/libstdc++.so.6(+0x8f2c1)[0x7fdc65d462c1]
/usr/lib/libstdc++.so.6(+0x8f4d8)[0x7fdc65d464d8]
/usr/lib/libreoffice/program/libutllo.so(+0x584c1)[0x7fdc60f544c1]
/usr/lib/libreoffice/program/libutllo.so(+0x59c7f)[0x7fdc60f55c7f]
/usr/lib/libreoffice/program/libutllo.so(+0x5a91a)[0x7fdc60f5691a]
/usr/lib/libreoffice/program/libutllo.so(_ZN3utl10ConfigItemC2ERKN3rtl8OUStringE14ConfigItemMode+0x84)[0x7fdc60f47114]
/usr/lib/libreoffice/program/libutllo.so(+0xbca21)[0x7fdc60fb8a21]
/usr/lib/libreoffice/program/libutllo.so(_ZN19SvtSysLocaleOptionsC1Ev+0x85)[0x7fdc60fb9065]
/usr/lib/libreoffice/program/libutllo.so(+0xe6363)[0x7fdc60fe2363]
/usr/lib/libreoffice/program/libutllo.so(_ZN12SvtSysLocaleC1Ev+0x55)[0x7fdc60fe2445]
/usr/lib/libreoffice/program/libvcllo.so(+0x3ee18c)[0x7fdc60acb18c]
/usr/lib/libreoffice/program/libvcllo.so(_ZN11AllSettingsC1Ev+0x46)[0x7fdc60acb2c6]
/usr/lib/libreoffice/program/libvcllo.so(+0x3f1c0f)[0x7fdc60acec0f]
/usr/lib/libreoffice/program/libvcllo.so(_ZN11Application11GetSettingsEv+0x32)[0x7fdc60acfaa2]
/usr/lib/libreoffice/program/libvclplug_gtk3lo.so(+0x40f62)[0x7fdc4db84f62]
/usr/lib/libreoffice/program/libvcllo.so(_Z7InitVCLv+0x2aa)[0x7fdc60ad478a]
/usr/lib/libreoffice/program/libvcllo.so(+0x3f854d)[0x7fdc60ad554d]
/usr/lib/libreoffice/program/libvcllo.so(_Z6SVMainv+0x22)[0x7fdc60ad55a2]
/usr/lib/libreoffice/program/libsofficeapp.so(soffice_main+0x8a)[0x7fdc66a546ca]
/usr/lib/libreoffice/program/soffice.bin[0x4006db]
/usr/lib/libc.so.6(__libc_start_main+0xf1)[0x7fdc66688291]
/usr/lib/libreoffice/program/soffice.bin[0x40071a]
Comment by Andreas Radke (AndyRTR) - Monday, 22 August 2016, 19:52 GMT
Please make sure it's not a graphics driver / mesa / theme bug. Make sure to disable OpenGL usage in LibO options.
These packages often cause such bugs. So please downgrade related packages
or test with a new user/clean environment with default theme. A segfault in uno can also be caused by some buggy LibO extensions.
Comment by sekret (sekret) - Monday, 22 August 2016, 20:15 GMT
Ok I created a new user, used it to launch libreoffice, same result.
I installed libreoffice in a clean chroot (which I have for building packages) and launched it in there, still the same result.

I use libreoffice without any addons, no custom theme or whatever. I just installed it and use it, when I need it. So the only thing I can think of is a mesa / graphics driver issue. I'll do further testing with previous versions of those tomorrow.
Comment by Andreas Radke (AndyRTR) - Tuesday, 23 August 2016, 07:51 GMT
Could this be a duplicate of  FS#50289  ? Looks similar though I see you have it installed but maybe not a required theme or something else.
Comment by sekret (sekret) - Tuesday, 23 August 2016, 07:56 GMT
Yeah looks exactly like my problem! I only searched for bug reports with libreoffice-still, should have searched for libreoffice-fresh aswell. My bad! ;) Thanks for pointing this out!
Comment by sekret (sekret) - Tuesday, 23 August 2016, 07:59 GMT
Ok, the last comment on that bugreport solved it, I installed dconf, now libreoffice launches without any output on the terminal.

So, what we learn from this is: dconf needs to be added as a dependency!
Comment by sekret (sekret) - Tuesday, 23 August 2016, 08:00 GMT
And thanks for your help! :)

Loading...