Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#50461 - [lib32-libcurl-compat] undefined symbol: libssh2_init

Attached to Project: Community Packages
Opened by Rin Cat (RinCat) - Saturday, 20 August 2016, 19:12 GMT
Last edited by Doug Newgard (Scimmia) - Monday, 22 August 2016, 04:31 GMT
Task Type Bug Report
Category Packages: Multilib
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
New Multilib version got error "undefined symbol: libssh2_init".
The old AUR version works fine.

Additional info:
lib32-libcurl-compat 7.50.1-2
lib32-libssh2 1.7.0-2

dontstarve_dedicated_server_nullrenderer: /usr/lib32/libcurl-gnutls.so.4: no version information available (required by dontstarve_dedicated_server_nullrenderer)
dontstarve_dedicated_server_nullrenderer: symbol lookup error: /usr/lib32/libcurl-gnutls.so.4: undefined symbol: libssh2_init

Steps to reproduce:
Install Don't starve together dedicated server from Steam.
Symbolic linked /usr/lib32/libcurl-compat.so.4.4.0 to /usr/lib32/libcurl-gnutls.so.4 for Don't starve together dedicated server compact.
Start server.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Monday, 22 August 2016, 04:31 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Don't create dumb symlinks

Loading...