FS#50403 - [systemd] systemctl start command showing not-found service when using bash-completion feature

Attached to Project: Arch Linux
Opened by Leonardo Santana Vieira (leosanvieira) - Monday, 15 August 2016, 16:53 GMT
Last edited by Dave Reisner (falconindy) - Saturday, 08 October 2016, 18:29 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Dave Reisner (falconindy)
Architecture x86_64
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 7
Private No



Every time i try starting a service and autocompleting it's name in bash, issuing a command like 'systemctl start reflector.service', it shows a message about a not-found service like below.

systemctl start refUnit auditd.service could not be found.

I tried masking auditd.service but then it just showed 'Unit plymouth-quit-wait.service could not be found.' instead.

It seems it's following the list of not-found services below.

systemctl --all --state=not-found

● auditd.service not-found inactive dead auditd.service
● plymouth-quit-wait.service not-found inactive dead plymouth-quit-wait.service
● plymouth-quit.service not-found inactive dead plymouth-quit.service
● plymouth-start.service not-found inactive dead plymouth-start.service
● rc-local.service not-found inactive dead rc-local.service
● syslog.service not-found inactive dead syslog.service

As a temporary workaround, i masked all not-found services and that solved the issue. But i don't think bash-completion showing this message concatenated inside the actual command is the right behaviour.

Before anyone asks, this is a new install and none of the services have been installed or uninstalled manually before.

Additional info:
systemctl --version
systemd 231

Steps to reproduce:
Try bash autocomplete feature issuing 'systemctl start' command with any service name and having not-found services as described above.
This task depends upon

Closed by  Dave Reisner (falconindy)
Saturday, 08 October 2016, 18:29 GMT
Reason for closing:  Fixed
Additional comments about closing:  systemd-231-4
Comment by Dave Reisner (falconindy) - Tuesday, 16 August 2016, 01:49 GMT
Please report this upstream. Arch won't do anything to fix this locally.
Comment by Chaoren Lin (chaoren) - Tuesday, 16 August 2016, 03:39 GMT Comment by Dave Reisner (falconindy) - Wednesday, 05 October 2016, 11:56 GMT
3967 was rejected/closed, but this appears to be a fix: