Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#50376 - [virtualbox-guest-modules-arch] vboxvideo fails to load

Attached to Project: Community Packages
Opened by Norbert Pfeiler (npfeiler) - Saturday, 13 August 2016, 01:55 GMT
Last edited by Sébastien Luttringer (seblu) - Sunday, 26 March 2017, 22:23 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sébastien Luttringer (seblu)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

> sudo insmod /lib/modules/4.7.0-1-ARCH/extramodules/vboxvideo.ko.gz
insmod: ERROR: could not insert module /lib/modules/4.7.0-1-ARCH/extramodules/vboxvideo.ko.gz: Invalid parameters

the command is taken from `modprobe -v` since that only reports an unhelpful »modprobe: ERROR: could not insert 'vboxvideo': Invalid argument«

using community/virtualbox-guest-modules-arch 5.1.2-2

host is win10

This has been an issue for longer than the last version.
This task depends upon

Closed by  Sébastien Luttringer (seblu)
Sunday, 26 March 2017, 22:23 GMT
Reason for closing:  Fixed
Comment by Doug Newgard (Scimmia) - Saturday, 13 August 2016, 13:51 GMT
What is the output of uname -a?
Comment by Norbert Pfeiler (npfeiler) - Saturday, 13 August 2016, 13:56 GMT
Linux arch-vm 4.7.0-1-ARCH #1 SMP PREEMPT Mon Aug 8 22:05:58 CEST 2016 x86_64 GNU/Linux

i noticed that i start my vm with nomodeset (which isn’t mentioned in the wiki), without it i get a kernel null deref
Comment by Enzo (Garret) - Friday, 19 August 2016, 07:31 GMT
I am experiencing issues in getting a functioning Xorg server on my Archlinux guest machine on a Win10 host. I have posted my issue on the bulletin board ( https://bbs.archlinux.org/viewtopic.php?pid=1648314 ). Probably this bug is related?
Comment by Christian Hesse (eworm) - Friday, 19 August 2016, 07:46 GMT
First of all you should not use insmod. Load your modules with modprobe.

vboxvideo from virtualbox-guest-modules-arch 5.1.2-2 was broken. Please update to version 5.1.2-3 and try again.
Probably a duplicate of  FS#50382 ...
Comment by Norbert Pfeiler (npfeiler) - Friday, 19 August 2016, 20:45 GMT
As explained, i only used insmod for a more descriptive error message.

This is the nomodeset counterpart to https://bugs.archlinux.org/task/50382 and https://bugs.archlinux.org/task/49752.

w/ KMS vboxvideo is loaded as a kernel module but cancels during xorg startup

[ 35.381] (II) vboxvideo: kernel driver found, not loading.
[ 35.382] (II) vboxvideo: kernel driver found, not loading.

w\ KMS xorg loads vboxvideo although it isn’t loadable through modprobe (this bug report)

[ 30.181] (II) VBoxVideo(0): VirtualBox guest additions video driver version 5.1.2_OSEr108956

I don’t know if vboxvideo is just not meant to be used w\ KMS but it isn’t working w/ KMS either…

Loading...