Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#50370 - [dkms] Removal of linux-docs removes dkms modules

Attached to Project: Arch Linux
Opened by Jan Steffens (heftig) - Friday, 12 August 2016, 15:59 GMT
Last edited by Sébastien Luttringer (seblu) - Sunday, 01 January 2017, 05:23 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Sébastien Luttringer (seblu)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Removing the linux-docs package, if installed, will also remove all DKMS modules installed for that kernel.

I think the install hook should also trigger on Remove operations, check if the kernel is still installed, and if so, reinstall the modules.

I don't think the removal can be avoided. You can't know pre-transaction whether a directory scheduled for removal will truly be removed, or remains because it's not empty.
This task depends upon

Closed by  Sébastien Luttringer (seblu)
Sunday, 01 January 2017, 05:23 GMT
Reason for closing:  Fixed
Comment by Sébastien Luttringer (seblu) - Friday, 19 August 2016, 00:50 GMT
ok, I'm able to reproduce.
Comment by Sébastien Luttringer (seblu) - Thursday, 03 November 2016, 22:59 GMT
Should be fixed is in testing.

Loading...