Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#50360 - absolutely massive performance drop (3x slower) on ARMv7 compared to devuan

Attached to Project: Arch Linux
Opened by luke kenneth casson leighton (lkcl) - Thursday, 11 August 2016, 19:09 GMT
Last edited by Antonio Rojas (arojas) - Thursday, 11 August 2016, 19:53 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

I'm running a crowd-funding campaign until the 26th august so have been evaluating a large range of different GNU/Linux distros running
on an Allwinner A20 which is a dual-core ARM Cortex A7
http://crowdsupply.com/eoma68/micro-desktop - demonstration videos are available via the "updates" page.

The difference in running libreoffice and web browsers on Parabola and Devuan is so stark that i can't not report this. The performance difference is *literally* a 3 times speed drop on Parabola / Arch-Linux.

isacdaavid tells me that Parabola uses libreoffice straight out of the arch-linux arm repository.

what i suspect is that the build configuration options haven't been assessed for speed optimisation. it genuinely, genuinely matters: firefox and webkit-based browsers are so slow as to be unusable. libreoffice takes FIFTEEN SECONDS to load up, and over TWELVE seconds just to render the print dialog. by contrast these times are cut to around 4 to 5 seconds on devuan.

this is so severe i'm raising it as a "High" bugreport. i can't however change priority to "low" - there doesn't appear to be one - which i would normally do, as although it's definitely "High severity" it's also not affecting functionality... it's just horribly slow.

interestingly there's no armv7hf architecture listed in the dropdown, which seems to be an oversight?

Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:

(1) install libreoffice and any web browser on arch linux arm. run them.
(2) install libreoffice and any web browser on devuan arm. run them.

This task depends upon

Closed by  Antonio Rojas (arojas)
Thursday, 11 August 2016, 19:53 GMT
Reason for closing:  Not a bug
Comment by Antonio Rojas (arojas) - Thursday, 11 August 2016, 19:53 GMT
It's not an oversight, arch linux doesn't support arm. ArchLinuxARM is a different distro

Loading...