Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#50333 - [libasyncns] Remove overlinking to libnsl

Attached to Project: Arch Linux
Opened by userwithuid (userwithuid) - Wednesday, 10 August 2016, 02:59 GMT
Last edited by Jan Alexander Steffens (heftig) - Wednesday, 10 August 2016, 23:11 GMT
Task Type General Gripe
Category Packages: Extra
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The current build (libasyncns 0.8-5) links the library to glibc's libnsl.so.1 without using any of its functions.

It's also a libtool shared library build, so the default arch linker flag that would fix this (-Wl,--as-needed) is ignored.

Solution: Add
-----
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
-----
or similar to the PKGBUILD as is done in many other packages.
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Wednesday, 10 August 2016, 23:11 GMT
Reason for closing:  Fixed

Loading...