Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#50306 - [qtractor] segfault on start

Attached to Project: Arch Linux
Opened by Philipp Überbacher (hollunder) - Sunday, 07 August 2016, 18:52 GMT
Last edited by Doug Newgard (Scimmia) - Sunday, 07 August 2016, 21:53 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I tried to record some stuff and after ardour segfaulted on me, I tried qtractor, which segfaulted on startup. I had to resort to audacity, which still works. I suspect gcc to be the culprit.

Additional info:
* package version(s)
qtractor 0.7.5-1
* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Doug Newgard (Scimmia)
Sunday, 07 August 2016, 21:53 GMT
Reason for closing:  Not a bug
Additional comments about closing:  See last comment
Comment by Doug Newgard (Scimmia) - Sunday, 07 August 2016, 19:29 GMT
got a backtrace?
Comment by Philipp Überbacher (hollunder) - Sunday, 07 August 2016, 20:35 GMT
Sadly, no, this is all I get:

$ qtractor
Segmentation fault (core dumped)

I am on x86_64. Same if I start jackd beforehand.
Comment by Doug Newgard (Scimmia) - Sunday, 07 August 2016, 20:51 GMT
So get one. Either use coredumpctl gdb or run the program in gdb.
Comment by Philipp Überbacher (hollunder) - Sunday, 07 August 2016, 21:32 GMT
Smartass, like I do this every day...
And what good is it without debug symbols?

$ coredumpctl gdb qtractor
PID: 1318 (qtractor)
UID: 1000 (murks)
GID: 100 (users)
Signal: 11 (SEGV)
Timestamp: Sun 2016-08-07 22:35:10 CEST (55min ago)
Command Line: qtractor
Executable: /usr/bin/qtractor
Control Group: /user.slice/user-1000.slice/session-c1.scope
Unit: session-c1.scope
Slice: user-1000.slice
Session: c1
Owner UID: 1000 (murks)
Boot ID: c69000caf9eb45359df84ab2c8b8641b
Machine ID: 7de9f5a7dad3440b9c050c3ae950c2ab
Hostname: eeyore
Coredump: /var/lib/systemd/coredump/core.qtractor.1000.c69000caf9eb45359df84ab2c8b8641b.1318.1470602110000000000000.lz4
Message: Process 1318 (qtractor) of user 1000 dumped core.

Stack trace of thread 1318:
#0 0x00007f1db35be5ce plugin_load (dssi.so)
#1 0x00007f1db35be1cf pluglib_load (dssi.so)
#2 0x00007f1db33b96d5 nabrit_util_load_all_in_dir (libnabrit.so.3)
#3 0x00007f1db35be100 bridge_load_all (dssi.so)
#4 0x00007f1dcec7069d lilv_world_load_dyn_manifest (liblilv-0.so.0)
#5 0x00007f1dcec709af load_dir_entry (liblilv-0.so.0)
#6 0x00007f1dcec6ebe6 lilv_dir_for_each (liblilv-0.so.0)
#7 0x00007f1dcec6f20b lilv_world_load_directory (liblilv-0.so.0)
#8 0x00007f1dcec70aee lilv_world_load_path (liblilv-0.so.0)
#9 0x00000000004cb597 n/a (qtractor)
#10 0x00000000005fa5b7 n/a (qtractor)
#11 0x00000000005fcbe0 n/a (qtractor)
#12 0x000000000044d15e n/a (qtractor)
#13 0x00007f1dcc1742d1 __libc_start_main (libc.so.6)
#14 0x000000000044fbe9 n/a (qtractor)

Stack trace of thread 1319:
#0 0x00007f1dcc2334cd poll (libc.so.6)
#1 0x00007f1dc794f8e0 n/a (libxcb.so.1)
#2 0x00007f1dc7951679 xcb_wait_for_event (libxcb.so.1)
#3 0x00007f1dc38ad469 n/a (libQt5XcbQpa.so.5)
#4 0x00007f1dcd05dd78 n/a (libQt5Core.so.5)
#5 0x00007f1dccd9b474 start_thread (libpthread.so.0)
#6 0x00007f1dcc23c81f __clone (libc.so.6)

Stack trace of thread 1320:
#0 0x00007f1dcc2334cd poll (libc.so.6)
#1 0x00007f1dc9865fd6 n/a (libglib-2.0.so.0)
#2 0x00007f1dc98660ec g_main_context_iteration (libglib-2.0.so.0)
#3 0x00007f1dcd28c57f _ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE (libQt5Core.so.5)
#4 0x00007f1dcd2360da _ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE (libQt5Core.so.5)
#5 0x00007f1dcd0590f3 _ZN7QThread4execEv (libQt5Core.so.5)
#6 0x00007f1dc16efe75 n/a (libQt5DBus.so.5)
#7 0x00007f1dcd05dd78 n/a (libQt5Core.so.5)
#8 0x00007f1dccd9b474 start_thread (libpthread.so.0)
#9 0x00007f1dcc23c81f __clone (libc.so.6)

GNU gdb (GDB) 7.11.1
Copyright (C) 2016 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-pc-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from /usr/bin/qtractor...(no debugging symbols found)...done.
[New LWP 1318]
[New LWP 1319]
[New LWP 1320]

warning: Could not load shared library symbols for linux-vdso.so.1.
Do you need "set solib-search-path" or "set sysroot"?
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
Core was generated by `qtractor'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0 0x00007f1db35be5ce in plugin_load (pluglib=pluglib@entry=0x2b6ced0, desc=0x2b6ce40) at plugin.c:126
126 plugin.c: No such file or directory.
[Current thread is 1 (Thread 0x7f1dd0c28800 (LWP 1318))]
Comment by Doug Newgard (Scimmia) - Sunday, 07 August 2016, 21:44 GMT
I can't find a dssi.so in the repos, what is this?
Comment by Philipp Überbacher (hollunder) - Sunday, 07 August 2016, 21:50 GMT
OK, since I got irritated by the "126 plugin.c: No such file or directory." I uninstalled all ladspa and lv2 stuff and qtractor started to work again. In all likelihood it was some version of those plugin libraries that caused the error. Sorry for the fuss.
Comment by Philipp Überbacher (hollunder) - Sunday, 07 August 2016, 21:51 GMT
DSSI is a instrument plugin format, pretty much the same generation as LADSPA (eg. pre-LV2)
Comment by Doug Newgard (Scimmia) - Sunday, 07 August 2016, 21:53 GMT
The library/plugin dssi.so seems to be what's causing the issue. Since this isn't something from Arch, there's nothing to be done here.

Loading...