Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#50303 - [ffmpeg] cannot play itunes created m4a files with mpd-0.19.18-1

Attached to Project: Arch Linux
Opened by John (graysky) - Sunday, 07 August 2016, 14:22 GMT
Last edited by Gaetan Bisson (vesath) - Tuesday, 23 August 2016, 23:22 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Maxime Gauduin (Alucryd)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Since updating to mpd-0.19.18-1, mpd is unable to play itunes created m4a audio files. The log file offers simply:
"Aug 07 10:19 : ffmpeg: avcodec_send_packet() failed: Invalid data found when processing input" which is repeated many times (my log file was 200 M of these). Downgrading to 0.19.17-2 fixes this issue. I do not know if this is an mpd problem or as ffmpeg problem.

ffmpeg-1:3.1.1-3
mpd-0.19.18-1
This task depends upon

Closed by  Gaetan Bisson (vesath)
Tuesday, 23 August 2016, 23:22 GMT
Reason for closing:  Fixed
Additional comments about closing:  mpd-0.19.19-1 in [extra]
Comment by Gaetan Bisson (vesath) - Sunday, 07 August 2016, 17:56 GMT
Could you please report this upstream? Please provide a sample m4a file and the output of `mpv --v`.
Comment by John (graysky) - Sunday, 07 August 2016, 18:12 GMT
I can report it upstream but I wasn't clear whether it should go against mpd or ffmpeg. Also, sharing my m4a files would violate the copyright on them. I will see if I can find an m4a that is public domain for this purpose.

...can anyone else reproduce my bug?
Comment by Gaetan Bisson (vesath) - Sunday, 07 August 2016, 18:44 GMT
Sorry but I have no m4a file on my system.

To tell whether it is a ffmpeg issue you can try playing your file directly with `ffplay`. (Though I assume it is an mpd issue.)
Comment by John (graysky) - Sunday, 07 August 2016, 20:17 GMT
Good idea; ffplay has no issues. For reference: `wget http://cdn.online-convert.com/example-file/audio/example.m4a`
Comment by John (graysky) - Sunday, 07 August 2016, 20:43 GMT Comment by John (graysky) - Monday, 15 August 2016, 18:38 GMT
Upstream (mpd) has closed the ticket I mentioned suspecting that the bug lies with ffmpeg. Can someone edit this ticket removing the mpd tag? I am building ffmpeg from git now prior to reporting to them.
Comment by John (graysky) - Monday, 15 August 2016, 19:16 GMT Comment by Götz (goetzc) - Tuesday, 16 August 2016, 17:06 GMT
It seems to be a bug in MPD introduced in 0.19.18, which prevents playing m4a files.
Comment by John (graysky) - Tuesday, 16 August 2016, 18:55 GMT
@gotz - did you read the upstream bug reports I linked???
Comment by Götz (goetzc) - Tuesday, 16 August 2016, 21:09 GMT
Yes John, both of them, why? Thanks for reporting those issues! I'm also affected.

Would be great if a backport fix could be applied to Arch's MPD package when it's available.

EDIT: Patch for mpd https://bugs.musicpd.org/file_download.php?file_id=1413&type=bug
Comment by John (graysky) - Tuesday, 23 August 2016, 23:00 GMT
19.19-1 fixes it for me. Safe to close.

Loading...