Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#50302 - [mongodb] Unable to start mongod with --fork

Attached to Project: Community Packages
Opened by Nicolas Di Pietro (potens) - Sunday, 07 August 2016, 13:44 GMT
Last edited by Antonio Rojas (arojas) - Tuesday, 23 April 2019, 15:35 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Felix Yan (felixonmars)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

When trying to start mongodb with the --fork flag, the server does not start, it prints

about to fork child process, waiting until server is ready for connections.

and then, the process seems to be frozen, cpu usage stay at 0% and memory seems very low for such a process (135m VIRT, 27m RES). No Fd's are reserved for logfiles or dbfiles, no log created.

Additional info:
* package version(s):
db version v3.2.8
git version: ed70e33130c977bda0024c125b56d159573dbaf0
OpenSSL version: OpenSSL 1.0.2h 3 May 2016
allocator: tcmalloc
modules: none
build environment:
distarch: x86_64
target_arch: x86_64

* config, log: None
* Not found a lot about this problem on the net, in fact only occurrence is in arch forum, and no answer on it.

Steps to reproduce:
mkdir /tmp/mongo && mongod --fork --logpath /tmp/mongo --dbpath /tmp/mongo --nojournal --smallfiles
This task depends upon

Closed by  Antonio Rojas (arojas)
Tuesday, 23 April 2019, 15:35 GMT
Reason for closing:  Won't fix
Additional comments about closing:  mongodb has been dropped
Comment by Felix Yan (felixonmars) - Monday, 05 September 2016, 17:13 GMT
Confirmed.

BTW: You need to specify a full path for --logpath.
Comment by Roukun (roukun1254) - Thursday, 01 June 2017, 14:34 GMT
Any news on this bug?
Comment by Felix Yan (felixonmars) - Friday, 02 June 2017, 03:55 GMT
No. Let me know if you think this is a packaging issue.
Comment by Artur Korobeynykl (arturk) - Thursday, 05 October 2017, 10:06 GMT
Same issue. Tried to remove, repackage. mongod works fine unless fork option is used, in this case it hangs forever. The port is not opened and the logfile is not created so something fails before forking and process is never started (as log is not created).

Loading...