Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#50295 - [graphicsmagick] compile --with-quantum-depth=32

Attached to Project: Arch Linux
Opened by Siddharth J Singh (dante666) - Sunday, 07 August 2016, 09:18 GMT
Last edited by Gaetan Bisson (vesath) - Sunday, 07 August 2016, 17:51 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Ronald van Haren (pressh)
Gaetan Bisson (vesath)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Compiling graphics--with-quantum-depth=16 results in the following warning in octave. Can we compile it using 32 bit depth?
http://wiki.octave.org/GraphicsMagick
(Please note that in the site it shows 8 bit depth and the solution is to compile with 16 bit depth. Probably for older times.)
http://wiki.octave.org/GraphicsMagick

>>warning: your version of GraphicsMagick limits images to 16 bits per pixel"
>>warning: called from
>> imformats>default_formats at line 256 column 11
>> imformats at line 79 column 3
>> imageIO at line 106 column 11
>> imread at line 106 column 30

Additional info:
* Version : 1.3.24-1

Steps to reproduce:
1) Start octave(tested with 4.0.3)
2) run imread("image.jpg")
This task depends upon

Closed by  Gaetan Bisson (vesath)
Sunday, 07 August 2016, 17:51 GMT
Reason for closing:  Won't implement
Comment by Doug Newgard (Scimmia) - Sunday, 07 August 2016, 12:55 GMT
This was tried, but reverted because of  FS#38273 
Comment by Gaetan Bisson (vesath) - Sunday, 07 August 2016, 17:51 GMT
Thanks Doug for digging up the reference!

Loading...