Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#50278 - [gsfonts] Firefox uses regular font instead of bold

Attached to Project: Arch Linux
Opened by Simon Sapin (SimonSapin) - Saturday, 06 August 2016, 09:55 GMT
Last edited by Gaetan Bisson (vesath) - Tuesday, 13 September 2016, 01:31 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Gaetan Bisson (vesath)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Since upgrading the gsfonts package from 20150811-1 to 20160531-3 (reverting fixes the issue), Firefox stopped using a bold font (using a regular weight font instead) in some cases where 'font-weight: bold' is specified, for example on GitHub for user names.

Steps to reproduce (… at least on my system):

* Install gsfonts (possibly as a dependency of evince) and Firefox
* In Firefox, navigate to https://github.com/rust-lang/rust/issues/35408
* At the end of the first message, "@rust-lang/compiler" should be in a bolder font than the rest of the message. On my system with up-to-date packages, it has the same (regular weight) font as the rest of the message. The Fonts panel of developer tools shows that "NimbusSans-Regular" is used, even though /usr/share/fonts/OTF/NimbusSans-Bold.otf exists next to /usr/share/fonts/OTF/NimbusSans-Regular.otf.

Steps to confirm responsible package:

* Downgrade with "sudo pacman --needed -U /var/cache/pacman/pkg/gsfonts-20150811-1-any.pkg.tar.xz" (assuming this old version is in the cache)
* Restart Firefox
* Navigate to https://github.com/rust-lang/rust/issues/35408 again
* "@rust-lang/compiler" is now correctly in a bold font. The devtools show that "NimbusSanL-Bol" is used.
This task depends upon

Closed by  Gaetan Bisson (vesath)
Tuesday, 13 September 2016, 01:31 GMT
Reason for closing:  No response
Comment by Gaetan Bisson (vesath) - Saturday, 06 August 2016, 18:40 GMT
There was indeed an error spewd by the install scriptlet about some OTF font not properly declaring its weight. That's why I added "&>/dev/null" but now I cannot reproduce it. Could you please report this upstream? I'd really prefer not to edit the files in our PKGBUILD. Cheers.
Comment by Simon Sapin (SimonSapin) - Sunday, 07 August 2016, 14:01 GMT Comment by Simon Sapin (SimonSapin) - Friday, 26 August 2016, 15:09 GMT
No response so far.

Gaetan, do you have more details on what the issue is?
Comment by Gaetan Bisson (vesath) - Saturday, 27 August 2016, 03:43 GMT
Simon: First off, I cannot reproduce your issue. If I open the github issue page you've mentioned in Firefox, the font used for "@rust-lang/compiler" is "Roboto Medium" which is a remote font Firefox gets from "https://assets-cdn.github.com/static/fonts/roboto/roboto-medium.woff". So my first question to you is: why don't you get that font too? That's what github's CSS specifies.

Loading...