Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#50264 - [firefox] Unable to start firefox because of missing libvpx.so.4

Attached to Project: Arch Linux
Opened by Joshua Mendoza (jomendoz) - Friday, 05 August 2016, 01:29 GMT
Last edited by Doug Newgard (Scimmia) - Friday, 05 August 2016, 01:45 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I'm unable to run firefox because the newest package version seems to lack a dynamic lib called libvpx.so.4
I could use firefox normally in previous version.

Additional info:
* package version: 48.0
* config and/or log files etc:

$ firefox
XPCOMGlueLoad error for file /usr/lib/firefox/libxul.so:
libvpx.so.4: cannot open shared object file: No such file or directory
Couldn't load XPCOM.

There's no libvpx.so.4 in packaged files:

$ pacman -Ql firefox | egrep "lib.*.so" ⏎
firefox /usr/lib/firefox/browser/components/libbrowsercomps.so
firefox /usr/lib/firefox/gmp-clearkey/0.1/libclearkey.so
firefox /usr/lib/firefox/gtk2/libmozgtk.so
firefox /usr/lib/firefox/liblgpllibs.so
firefox /usr/lib/firefox/libmozavcodec.so
firefox /usr/lib/firefox/libmozavutil.so
firefox /usr/lib/firefox/libmozgtk.so
firefox /usr/lib/firefox/libxul.so


Steps to reproduce:
- Update from firefox 47.0.1 to firefox 48.0
- Execute firefox command on terminal.
- Error message is shown.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Friday, 05 August 2016, 01:45 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Partial updates are not supported.

Loading...