Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#50241 - [xf86-video-intel] The frame of a window and its open gl content are out of sync.

Attached to Project: Arch Linux
Opened by Manuel Schneider (manuelschneid3r) - Wednesday, 03 August 2016, 13:38 GMT
Last edited by Andreas Radke (AndyRTR) - Saturday, 18 February 2017, 21:40 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Laurent Carlier (lordheavy)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
The frame of a window and its open gl content are out of sync.
Check this screencast: https://youtu.be/c32nxfBk4fA

Additional info:
xorg-server 1.18.4
xorg-xdriinfo 1.0.5
xf86-video-intel 1:2.99.917+688+g49daf5d
libva-intel-driver 1.7.1


Steps to reproduce:
Just resize a windowed OpenGL application.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Saturday, 18 February 2017, 21:40 GMT
Reason for closing:  Upstream
Comment by patrick (potomac) - Wednesday, 03 August 2016, 15:29 GMT
no problem with my configuration, if I resize both length and width of the window then the content ( glxgears ) will be resized,

I have an amd radeon HD4650 pcie, radeon driver, mesa 12.0.1-5,

but I am not sure to understand your bugreport, you should tell exactly which package is the culprit ( you can do a downgrading in order to find the culprit )

Comment by Manuel Schneider (manuelschneid3r) - Wednesday, 03 August 2016, 15:39 GMT
I guess this is an intel problem. I have an Intel Core i5-4590 with Intel HD Graphics 4600. I am not sure which package causes this issue.

What sort of open gl does your setup support? (glxinfo | grep "OpenGL version")
Comment by patrick (potomac) - Wednesday, 03 August 2016, 18:51 GMT
my graphic card supports openGL 3.0 :

OpenGL version string: 3.0 Mesa 12.0.1
Comment by Andreas Radke (AndyRTR) - Thursday, 04 August 2016, 11:18 GMT
Can you workaround it with DRI2 fallback? Report it upstream in any way.
Comment by Manuel Schneider (manuelschneid3r) - Thursday, 04 August 2016, 11:20 GMT
I have absolutely no clue of graphic drivers. I could use some guidance. How do I get DRI2? And where is upstream? Is this clear to you where the problem is?
Comment by Manuel Schneider (manuelschneid3r) - Wednesday, 10 August 2016, 11:08 GMT
Bump. Do you know which piece of software causes this issue?
Comment by patrick (potomac) - Wednesday, 10 August 2016, 17:48 GMT
one way for finding the culprit is to downgrade some packages and see if the bug is still here or not :

- mesa packages
- linux kernel
- xorg

check your pacman.log, you will see packages which have been upgraded recently, one of them is probably the culprit
Comment by Manuel Schneider (manuelschneid3r) - Thursday, 01 September 2016, 19:03 GMT
That will not help. I have this problem since years. This is suddenly a critical bug since chromium switched to opengl. Mesa gears and my own QML application have this problem a long time. I really would like to report this bug upstream, but I have no clue where this is?

Can somebody please instruct me what to do?

As you said this looks like an intel problem. Which package contains the intel open gl driver?
Comment by Manuel Schneider (manuelschneid3r) - Thursday, 01 September 2016, 19:22 GMT
Indeed I could fix it by setting the option "DRI" "2". Any ideas on where to go?

I reported it here https://bugs.freedesktop.org/show_bug.cgi?id=97566

Is this the right place?
Comment by Manuel Schneider (manuelschneid3r) - Tuesday, 13 September 2016, 21:27 GMT
I think it necessary to take a deeper look. Archlinux performs somehow worse than ubuntu.

archlinux dri2
https://youtu.be/RxZ4qO3gpL8

archlinux dri3
https://youtu.be/EB0xabvo1Ew

ubuntu 16 04 dri2
https://youtu.be/eM6If13dgIA

ubuntu 16 04 dri3
https://youtu.be/9Upauh38jfw

Any ideas?

Loading...