Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#50237 - [poppler] cannot render a particular PDF document

Attached to Project: Arch Linux
Opened by Francesco Turco (fturco) - Wednesday, 03 August 2016, 06:26 GMT
Last edited by Andreas Radke (AndyRTR) - Friday, 05 August 2016, 19:58 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I'm running poppler-0.42.0-1 and evince-3.20.1-1.

I usually have no problem with this software combination, but now I found a PDF document that poppler/evince can't render correctly. Some text can't be read and embedded images aren't shown. The PDF document can be retrieved here: https://www.fturco.net/linux.pdf

I also tried to open this PDF with other programs (Mupdf and PDF.js) and they were able to display it correctly. So such PDF is not corrupt as far as I know.

I tried bypassing evince and producing a PNG image from the PDF document with pdftocairo:

pdftocairo -png linux.pdf -singlefile

You can download the PNG image here: https://www.fturco.net/linux.png

So I tried rebuilding poppler-0.42.0 with the following options:

1) --enable-libopenjpeg=openjpeg1: pdftocairo produces warnings and a broken PNG file
2) --enable-libopenjpeg=openjpeg2: pdftocairo produces a good PNG file with no warnings at all
3) --enable-libopenjpeg=auto: it selects version 1; pdftocairo produces warnings and a broken PNG file

I suggest to add --enable-libopenjpeg=openjpeg2 to the PKGBUILD as it seems better.

Please also see:
- https://bugs.freedesktop.org/show_bug.cgi?id=97183
- https://bugzilla.gnome.org/show_bug.cgi?id=769380
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Friday, 05 August 2016, 19:58 GMT
Reason for closing:  Fixed
Comment by Andreas Radke (AndyRTR) - Wednesday, 03 August 2016, 14:44 GMT
I'm now cc'ed to the upstream bug. We had already such a request in the past:  FS#47687  !

But time has progressed and I see Fedora and even Debian are using openjpeg2 now in their latest branches.
I would prefer upstream recommending this over old openjpeg (1). There was a question on the poppler ml without answer lately.

Maybe I will make the switch once the poppler 0.46.0/glew rebuilds are done.
Comment by Andreas Radke (AndyRTR) - Friday, 05 August 2016, 12:42 GMT
Please give poppler 0.46.0-2 in testing repo a try.
Comment by Francesco Turco (fturco) - Friday, 05 August 2016, 13:03 GMT
I built poppler-0.46.0-2 from https://git.archlinux.org/svntogit/packages.git/tree/poppler/trunk/PKGBUILD and then tested it. The pdftocairo command now produces a good PNG image, and Evince can display the original PDF without any problems. It seems the problem is fixed!

Loading...