Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#50186 - [gdm] Cannot resume session - pam_env error

Attached to Project: Arch Linux
Opened by Konstantin Gizdov (kgizdov) - Thursday, 28 July 2016, 16:42 GMT
Last edited by Jan Alexander Steffens (heftig) - Thursday, 29 December 2016, 11:09 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
GDM cannot resume session after lock screen. Trying to restart the service results in infinite loop and complete system lockup.

systemctl status gdm.service:
...
<date> <hostname> gdm-password][<squence num>]: pam-env(gdm-password:setcred): Unrecognised Option - ignoring line
<date> <hostname> gdm-password][<squence num>]: pam-env(gdm-password:setcred): Unrecognised Option - ignoring line
<date> <hostname> gdm-password][<squence num>]: pam-env(gdm-password:setcred): Unrecognised Option - ignoring line
<date> <hostname> gdm-password][<squence num>]: pam-env(gdm-password:setcred): Unrecognised Option - ignoring line

The trailing ']' is not a typo in the output. Not sure if that's not what is causing it.


Additional info:
* package version(s)
gdm 3.20.1-1
* config and/or log files etc.
no manual config files exist


Steps to reproduce:
- Login to Gnome
- Lock the screen with Ctrl+l
- Try to resume
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Thursday, 29 December 2016, 11:09 GMT
Reason for closing:  Works for me
Comment by Jan de Groot (JGC) - Wednesday, 02 November 2016, 09:33 GMT
Can't reproduce your bug. Do you have any customized files in /etc/pam.d/ that could cause this issue?
Comment by mattia (nTia89) - Wednesday, 28 December 2016, 17:19 GMT
I can't too reproduce this issue.
Because it has been reported with version 3.20, does latest GNOME version solve the issue?
Comment by Konstantin Gizdov (kgizdov) - Thursday, 29 December 2016, 10:15 GMT
I no longer experience this issue, so I think it is probably fixed in 3.22. Sorry, I forgot to update here.

Loading...