Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#50184 - [xdg-utils] xdg-open fails to use chromium

Attached to Project: Arch Linux
Opened by Shane (sdd76) - Thursday, 28 July 2016, 16:10 GMT
Last edited by Andreas Radke (AndyRTR) - Sunday, 31 July 2016, 09:30 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Architecture All
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Running "xdg-open ~/projects" results in the error:
/usr/bin/xdg-open: line 781: x-www-browser: command not found

I think this may be related to the xdg-open containing chromium-browser instead of just chromium. The chromium package just contains "chromium".

Additional info:
* package version(s)
* config and/or log files etc.

You have to have chromium installed.
Running xdg-open "http://linux.com" opens chromium correctly. I don't have the BROWSER environment variable set in my zshrc and it isn't in my env.

Steps to reproduce:
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Sunday, 31 July 2016, 09:30 GMT
Reason for closing:  Fixed
Additional comments about closing:  1.1.1-4
Comment by Shane (sdd76) - Thursday, 28 July 2016, 16:17 GMT
Using exo-open appears to work correctly and it is worth mentioning that after the error printed above, it does manage to launch Firefox instead of chromium but the error always appears.
Comment by Shane (sdd76) - Thursday, 28 July 2016, 16:27 GMT
If I remove Firefox I get a command not found error for all these and then it uses elinks:
X-www-browser
Firefox
Ice weasel
Seamonkey
Epiphany
Konqueror
Chromium-browser (this is installed as /usr/bin/chromium)
Www-browser
Links
Comment by Doug Newgard (Scimmia) - Thursday, 28 July 2016, 16:48 GMT
What is the output of `xdg-mime query default x-scheme-handler/http`?
Comment by Shane (sdd76) - Thursday, 28 July 2016, 17:03 GMT
I did this:
> xdg-mime query default inode/directory
dolphin.desktop
> xdg query filetype ~/projects
inode/directory

I can actually make the error go away entirely when I updated my ~/.config/mimeapps.list and add the line:

inode/directory=Thunar-folder-handler.desktop

in the [Default Applications] section. So I can get it to work. But that fall-through case is still broken which is why I reported it. The "chromium-browser" executable doesn't exist. When chromium is installed, it is just "chromium". I am a little baffled why it finds dolphin.desktop instead of org.kde.dolphin.desktop. I don't see that anywhere in my mimeapps.list, but meh. That's no big deal. I am mostly concerned about the fall-through case that calls chromium-browser.
Comment by Andreas Radke (AndyRTR) - Thursday, 28 July 2016, 17:10 GMT
Chromium ships this:

andyrtr@workstation64:/home/andyrtr $ cat /usr/share/applications/chromium.desktop | grep -i mime
MimeType=text/html;text/xml;application/xhtml+xml;text/mml;x-scheme-handler/http;x-scheme-handler/https;

Use mimeopen to set the desired default application. For more:
https://wiki.archlinux.org/index.php/Default_applications#Application_launchers

Looks like a user setup issue, not a bug.
Comment by Doug Newgard (Scimmia) - Thursday, 28 July 2016, 17:24 GMT
Yeah, I had misread earlier, thanks for giving me the info I wanted instead of the info I asked for :D

I so see what you're talking about, the xdg-open script is specifically hard-coded to chromium-browser. It should never get there, so this is really a non-issue.
Comment by Andreas Radke (AndyRTR) - Thursday, 28 July 2016, 20:46 GMT
xdg-open some-index.html works here.

https://cgit.freedesktop.org/xdg/xdg-utils/commit/?id=5c990c16f67a2b5856c03c2cb1204b4049e25cde - hardcodes the simple name
https://cgit.freedesktop.org/xdg/xdg-utils/commit/?id=5c990c16f67a2b5856c03c2cb1204b4049e25cde - enlarges this with custom default scheme handlers.

You can overwrite the local user mimetype default at any time with mimeopen.

So can we close this one?
Comment by Shane (sdd76) - Thursday, 28 July 2016, 21:36 GMT
I have it fixed on my machine and working. If you're okay with the hard coded chromium-browser value in xdg-open that doesn't work then go ahead and close it.

Loading...