Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#50182 - [mesa-libgl] Should conflict, not replace

Attached to Project: Arch Linux
Opened by Doug Newgard (Scimmia) - Thursday, 28 July 2016, 15:58 GMT
Last edited by Laurent Carlier (lordheavy) - Thursday, 28 July 2016, 18:42 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Laurent Carlier (lordheavy)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

replaces=('libgl' 'libgles' 'libegl')

Should likely be

conflicts=('libgl' 'libgles' 'libegl')
This task depends upon

Closed by  Laurent Carlier (lordheavy)
Thursday, 28 July 2016, 18:42 GMT
Reason for closing:  Fixed
Additional comments about closing:  mesa-12.0.1-5
Comment by Laurent Carlier (lordheavy) - Thursday, 28 July 2016, 16:02 GMT
oh, yes probably, let me check :)
Comment by Laurent Carlier (lordheavy) - Thursday, 28 July 2016, 16:05 GMT
Not sure for conflicts, because it could conflicts with packages providing libgl/libgles/libegl
Comment by Laurent Carlier (lordheavy) - Thursday, 28 July 2016, 16:06 GMT
From the wiki:
"An array of packages that conflict with, or cause problems with the package, if installed. All these packages and packages providing this item will need to be removed. The version properties of the conflicting packages can also be specified in the same format as the depends array. "
Comment by Doug Newgard (Scimmia) - Thursday, 28 July 2016, 16:24 GMT
Not understanding your last couple of comments. Packages providing libgl, for example, will have a file at /usr/lib/libGL.so, so they will always conflict. They should be marked as such.
Comment by Laurent Carlier (lordheavy) - Thursday, 28 July 2016, 18:42 GMT
Ok, i will use conflicts instead of replaces

Loading...