Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#50075 - [libnftnl] Move to core repository

Attached to Project: Arch Linux
Opened by Alif (alive4ever) - Sunday, 17 July 2016, 07:50 GMT
Last edited by Sébastien Luttringer (seblu) - Tuesday, 23 August 2016, 00:35 GMT
Task Type General Gripe
Category Packages: Extra
Status Closed
Assigned To Sébastien Luttringer (seblu)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
libntfl and libmnl are dependency of iptables. iptables is in core repository, so it would make sense for core packages to only depend on core package. 'base' group should depends only on core packages.

Fail to install iptables means fail to install systemd. Since many of base packages depend on systemd, this would break 'base' installation.

Additional info:
* package version(s): libntnfl 1.0.6-1
* config and/or log files etc.: none


Steps to reproduce:
Create a new pacman.conf file, disabling extra, community, and multilib repositories.
Bootstrap a base system using the specified pacman.conf file '$ pacstrap -i -c -d -C /tmp/pacman.conf /mnt/chroot base'.
Pacstrap will fail because of missing dependencies.

This task depends upon

Closed by  Sébastien Luttringer (seblu)
Tuesday, 23 August 2016, 00:35 GMT
Reason for closing:  Fixed
Comment by Alif (alive4ever) - Sunday, 17 July 2016, 07:55 GMT
I really mean libnftnl. Pardon my mistyping.
Comment by Doug Newgard (Scimmia) - Sunday, 17 July 2016, 13:14 GMT
Disabling Extra and Community is not supported, so this certainly isn't "Critical".
Comment by Sébastien Luttringer (seblu) - Monday, 18 July 2016, 21:14 GMT
iptables dependancy is recent. Will move it to core.
Comment by Alif (alive4ever) - Tuesday, 23 August 2016, 00:12 GMT
  • Field changed: Percent Complete (100% → 0%)
libmnl, which is libnftnl dependency still on extra. libmnl should be moved to core along with libnftnl.
Comment by Sébastien Luttringer (seblu) - Tuesday, 23 August 2016, 00:35 GMT
correct, done.

Loading...