AUR web interface

**This is the bug tracker for the AUR web interface.**

Use this tracker to report bugs or make feature requests regarding the behaviour or implementation of the AUR software.
Please read the Reporting Bug Guidelines before filing a new task.
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

- Please report bugs related to Arch Linux official packages here: http://bugs.archlinux.org/index.php?project=1
- Please report bugs for [community] packages here: http://bugs.archlinux.org/index.php?project=5
- For any packages in the AUR contact the maintainer or leave a comment on the package's detail page.

Source Code:
https://projects.archlinux.org/aurweb.git/
Tasklist

FS#50070 - Impossible for me to install qgis

Attached to Project: AUR web interface
Opened by Hodonou SOUNTON (iker) - Saturday, 16 July 2016, 14:35 GMT
Last edited by Lukas Fleischer (lfleischer) - Sunday, 14 August 2016, 19:51 GMT
Task Type Bug Report
Category PKGBUILD Parser
Status Closed
Assigned To No-one
Architecture All
Severity Critical
Priority Normal
Reported Version 4.2.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

$ yaourt -S qgis

==> Téléchargement du PKGBUILD de qgis depuis AUR...
x .SRCINFO
x .gitignore
x PKGBUILD
paneves commented on 2016-07-12 17:07
@ Scimmia: I did that. Now when I do pacaur -Syu or if I start from scratch and do makepkg inside the qgis folder the build process stops at around 24%
(building cxx object src/core(CMakeFiles(qgis_core.dir/composer/moc_qgscomposerobject.cxx.o) and my laptop completely freezes. I have to push the power button to restart it... I have around 38 Gb of free disk space.
I have grass gis installed from AUR, if it makes any difference...

Scimmia commented on 2016-07-13 00:00
@paneves, are you building in tmpfs?

paneves commented on 2016-07-13 08:55
@ Scimmia: No. I'm building in my home folder. I've double checked it. What puzzles me is that the laptop completely freezes - no warnings, no errors. I wonder if it could be a CPU temperature issue.
Version 2.14 of qgis build fine last time...

paneves commented on 2016-07-14 08:26
I've managed to build qgis 2.16 by logging out of my Plasma session and building the package on another tty.

Scimmia commented on 2016-07-14 14:32
I've added a patch from upstream to fix the single process build issue. No reason to bump the pkgrel, as it doesn't change anything other than the build process.

qgis 2.16.0-1 (2016-07-14 14:31)
( Paquet non supporté : peut être dangereux ! )
==> Éditer PKGBUILD ? [O/n] ("A" pour annuler)
==> ------------------------------------------
==> O

==> Dépendances de qgis :
- qca-qt4 (déjà installé)
- gdal (déjà installé)
- qwtpolar (déjà installé)
- spatialindex (déjà installé)
- python2-httplib2 (déjà installé)
- python2-future (déjà installé)
- python2-qscintilla-qt4 (déjà installé)
- python2-sip (déjà installé)
- python2-six (déjà installé)
- cmake (déjà installé) [makedepend]
- gsl (déjà installé) [makedepend]
- perl (déjà installé) [makedepend]
- txt2tags (déjà installé) [makedepend]


==> Lancer la compilation de qgis ? [O/n]
==> -------------------------------------
==>

==> Construction et installation du paquet
==> Création du paquet qgis 2.16.0-1 (sam. juil. 16 15:21:11 WAT 2016)
==> Vérification des dépendances pour l’exécution...
==> Vérification des dépendances pour la compilation...
==> Récupération des sources...
-> Téléchargement de qgis-2.16.0.tar.bz2...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:--:-- 0:00:08 --:--:-- 0
curl: (22) The requested URL returned error: 403 Forbidden
==> ERREUR : Erreur lors du téléchargement de https://qgis.org/downloads/qgis-2.16.0.tar.bz2
Abandon...
==> ERREUR : Makepkg n'a pas pu construire qgis.
==> Relancer la compilation de qgis ? [o/N]
==> ---------------------------------------
N
This task depends upon

Closed by  Lukas Fleischer (lfleischer)
Sunday, 14 August 2016, 19:51 GMT
Reason for closing:  Not a bug
Comment by Doug Newgard (Scimmia) - Saturday, 16 July 2016, 14:40 GMT
This has nothing to do with the AUR itself.

Loading...