Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#50055 - Huawei E1750 GSM modem doesn't switch after upgrade to the usb_modeswitch 2.4.0-1

Attached to Project: Community Packages
Opened by viktor (dviktor) - Friday, 15 July 2016, 18:58 GMT
Last edited by Doug Newgard (Scimmia) - Tuesday, 19 July 2016, 02:53 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
After upgrading usb_modeswitch from 2.3.0-1 to the 2.4.0-1 my Huawei E1750 GSM stick doesn't switch automatically to the correct mode. I need to do it manually by
$ sudo usb_modeswitch -v 0x12d1 -p 0x1446 -c 12d1:1446

Additional info:
* package version(s)
usb_modeswitch 2.4.0-1

Steps to reproduce:
plug in E7150 stick. while older version of usb_modeswitch did the switch automatically the newer one doesn't.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Tuesday, 19 July 2016, 02:53 GMT
Reason for closing:  Fixed
Additional comments about closing:  usb_modeswitch 2.4.0-2
Comment by KF (kecef) - Friday, 15 July 2016, 20:26 GMT
I have exactly the same issue after the upgrade but with a different modem - Huawei E353.
Comment by Milosz M (mdmilosz) - Friday, 15 July 2016, 23:22 GMT
The same with Huawei E3131.

Look also:
https://bugs.archlinux.org/task/50056
Comment by viktor (dviktor) - Saturday, 16 July 2016, 08:19 GMT
Seems like the problem is in the line with Android phones exclusion:

$ cat /lib/udev/rules.d/40-usb_modeswitch.rules | grep -i 12d1
ATTRS{idVendor}=="12d1", ATTRS{manufacturer}!="Android", ATTR{bInterfaceNumber}=="00", ATTR{bInterfaceClass}=="08", RUN+="usb_modeswitch '%b/%k'"
ATTR{idVendor}=="12d1", ATTR{idProduct}=="1573", RUN+="usb_modeswitch '%b/%k'"
ATTR{idVendor}=="12d1", ATTR{idProduct}=="15c1", RUN+="usb_modeswitch '%b/%k'"

UPD: excuse me, I've already seen your link. The problem is in systemd service file %)
Comment by viktor (dviktor) - Sunday, 17 July 2016, 17:59 GMT
seems like after today's update the problem is gone - after reboot i've got working Huawei E1750 in GSM mode

[viktor ~]$ cat /var/log/pacman.log | grep upgraded | grep 2016-07-17
[2016-07-17 16:55] [ALPM] upgraded hwids (20160306-1 -> 20160421-1)
[2016-07-17 16:55] [ALPM] upgraded pam (1.2.1-3 -> 1.3.0-1)
[2016-07-17 16:55] [ALPM] upgraded device-mapper (2.02.160-1 -> 2.02.160-2)
[2016-07-17 16:55] [ALPM] upgraded gettext (0.19.7-1 -> 0.19.8.1-2)
[2016-07-17 16:55] [ALPM] upgraded lftp (4.7.2-1 -> 4.7.3-1)
[2016-07-17 16:55] [ALPM] upgraded linux (4.6.3-1 -> 4.6.4-1)
[2016-07-17 16:55] [ALPM] upgraded linux-headers (4.6.3-1 -> 4.6.4-1)
[2016-07-17 16:55] [ALPM] upgraded opus (1.1.2-1 -> 1.1.3-2)
[2016-07-17 16:55] [ALPM] upgraded p7zip (15.14.1-2 -> 16.02-1)
[2016-07-17 16:55] [ALPM] upgraded python-psutil (4.2.0-1 -> 4.3.0-1)
[2016-07-17 16:55] [ALPM] upgraded sudo (1.8.16-1 -> 1.8.17.p1-1)
[2016-07-17 16:55] [ALPM] upgraded tdb (1.3.8-1 -> 1.3.9-1)
[2016-07-17 16:55] [ALPM] upgraded virtualbox-host-dkms (5.0.24-1 -> 5.1.0-1)
[2016-07-17 16:55] [ALPM] upgraded virtualbox (5.0.24-1 -> 5.1.0-1)
[2016-07-17 16:55] [ALPM] upgraded virtualbox-guest-iso (5.0.24-1 -> 5.1.0-1)
Comment by Cereal Killer (cerealkkiller) - Sunday, 17 July 2016, 19:07 GMT
I have a ZTE MF667 USB modem (Bus 002 Device 010: ID 19d2:0154) that is not switched after last update (2.4.0-1). Updating linux kernel to 4.6.4-1 did not fixed this. Modem still not working.

later edit:
for those in need of an urgent fix, you can downgrade using the Arch Linux Archive (https://archive.archlinux.org/) to the 2.3.0-1 version (https://archive.archlinux.org/packages/u/usb_modeswitch/usb_modeswitch-2.3.0-1-i686.pkg.tar.xz) that seems to work.
Alternatively you can use the pacman cache (/var/cache/pacman/pkg/) if you didn't delete that.
Comment by viktor (dviktor) - Sunday, 17 July 2016, 21:16 GMT
Yes, just tested after manual reconnect: switching still not working...
Comment by viktor (dviktor) - Monday, 18 July 2016, 19:43 GMT
the problem has gone with usb_modeswitch 2.4.0-2

Loading...