Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#50031 - [bird6] Bird connection issues over a GRE

Attached to Project: Arch Linux
Opened by Ruben Kelevra (RubenKelevra) - Wednesday, 13 July 2016, 13:10 GMT
Last edited by Sébastien Luttringer (seblu) - Thursday, 14 July 2016, 00:24 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Sébastien Luttringer (seblu)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I try to connect over a GRE-tunnel in a 5 to 6 machine setup.

On my 5 machines each of the other 6 machines are configured via netctl for a gre-tunnel.

With nmap I confirmed that the connections are possible (I've masked the IPv6-Numbers):

-----------------------------

# nmap -6 -p179 2a03:1234:2345:3456::1

Starting Nmap 7.12 ( https://nmap.org ) at 2016-07-13 14:53 CEST
Nmap scan report for 2a03:1234:2345:3456::1
Host is up (0.011s latency).
PORT STATE SERVICE
179/tcp open bgp

Nmap done: 1 IP address (1 host up) scanned in 6.79 seconds

-----------------------------

Additional info:
* package version(s)
1.6.0-1
* log shows to all peers something like this:
bb_b_ix_dus_abc: Connecting to 2a03:1234:2345:3456::1 from local address 2a03:1234:2345:3456::2


I've tcpdumped it locally, the SYN from bird6 never get responded, so I think there is an issue that this package never get it thru the GRE tunnel.

The exact same looking SYN from Telnet or Nmap got responded very well.
This task depends upon

Closed by  Sébastien Luttringer (seblu)
Thursday, 14 July 2016, 00:24 GMT
Reason for closing:  Not a bug

Loading...