Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#50012 - [jupyter] Python2 package does not install enough to open notebooks

Attached to Project: Community Packages
Opened by Connor Behan (connorbehan) - Sunday, 10 July 2016, 23:04 GMT
Task Type Bug Report
Category Packages
Status Assigned
Assigned To Kyle Keen (keenerd)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

The package "ipython2-notebook" should be enough to open a notebook with "ipython2 notebook foo.ipynb". Using this after the first installation however fails due to missing ipywidgets. It works if I rebuild the package by making copies of all 6 directories in prepare() instead of just 3. This makes the package_ipython2-notebook() function look almost the same as the package_jupyter() function.
This task depends upon

Comment by Kyle Keen (keenerd) - Monday, 11 July 2016, 00:03 GMT
Sorry, but that is running Jupyter via python2. "ipython2 notebook" is not supported. Use the python2-ipykernel and jupyter.

You are confused about the purpose of the ipython2-notebook package. To be fair I haven't exactly made it clear what the actual purpose of the package is, but mostly its for third party applications that integrate an ipython shell. It is not for hosting a notebook and the present name is mostly a historical accident.

While your exact issue is not a bug, it does reflect a legitimate documentation and naming issue. So I'm not going to close this immediately.
Comment by Connor Behan (connorbehan) - Monday, 11 July 2016, 01:42 GMT
The jupyter package depends on python3 though. If there's no [community] package that allows people with only python2 to open foo.ipynb, that should probably be fixed.
Comment by Kyle Keen (keenerd) - Monday, 11 July 2016, 01:45 GMT
Nope, that is not a bug. Jupyter supports any programming language. Python3-jupyter supports py2. Having a python2-jupyter would be needless duplication.
Comment by Connor Behan (connorbehan) - Monday, 11 July 2016, 02:10 GMT
So your view is that only libraries that provide an API should be split into "one with py2 dependencies" and "one with py3 dependencies"? That's fair enough. I also use a custom-built youtube-dl for this reason. Maybe I'll put them in the AUR for people who want to save space.
Comment by Kyle Keen (keenerd) - Monday, 11 July 2016, 02:21 GMT
Your time would probably be better spent porting the last few python2 holdouts to python3. It's nicer over here.

But the AUR works. Feel free to email me if you have any questions about further stuff.

Still keeping this open because I'm not happy with the ipython2-notebook package.

Loading...