Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#50008 - [bmon] crashed in high network traffic(segfault)

Attached to Project: Community Packages
Opened by Zack Ceng (knight42) - Sunday, 10 July 2016, 11:32 GMT
Last edited by Doug Newgard (Scimmia) - Tuesday, 19 July 2016, 03:08 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Crashed when I upload/download large files(aboout 2MB/s). However, If I clone the project from github and compile it on my machine, bmon works fine. I suspect the problem is related to packaging.

dmesg output:
[26891.861402] bmon[6242]: segfault at 7ffc384b9ff8 ip 00007f9c4d4c641b sp 00007ffc384ba000 error 6 in libc-2.23.so[7f9c4d454000+197000]

[26898.142145] bmon[6300]: segfault at 7ffc8001cf78 ip 00007f4026c5abcb sp 00007ffc8001cf80 error 6 in libc-2.23.so[7f4026c14000+197000]

[28170.247893] bmon[14149]: segfault at 7ffd619a5fa8 ip 00007f88830fabcb sp 00007ffd619a5fb0 error 6 in libc-2.23.so[7f88830b4000+197000

Steps to reproduce:
This task depends upon

Closed by  Doug Newgard (Scimmia)
Tuesday, 19 July 2016, 03:08 GMT
Reason for closing:  No response
Additional comments about closing:  Possibly a bug fixed upstream?
Comment by Doug Newgard (Scimmia) - Monday, 11 July 2016, 00:48 GMT
You mention cloning it on github, are you building from HEAD or from the tag? If from HEAD, it's going to be completely different than the package.
Comment by Doug Newgard (Scimmia) - Wednesday, 13 July 2016, 00:17 GMT
Ping?

Loading...