Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#50006 - gimp package needs to depend on webkitgtk2

Attached to Project: Arch Linux
Opened by Ahmed W. (OneOfOne) - Saturday, 09 July 2016, 17:36 GMT
Last edited by Doug Newgard (Scimmia) - Sunday, 10 July 2016, 02:49 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description: the gimp depends on webkitgtk2, however the package doesn't pull it in.


Additional info:
* package version(s)
* config and/or log files etc.

extra/gimp 2.8.16-2

webkitgtk2 should be at least an optional dep.

Steps to reproduce:

1. Install the gimp without webkitgtk2.
2. Try to load the help-browser or web-page plugins.
3. Watch it crash and burn.

GDK_IS_DEVICE (device)) || (GDK_IS_DEVICE (info->device) && device == NULL)' failed
/usr/lib/gimp/2.0/plug-ins/help-browser: error while loading shared libraries: libwebkitgtk-1.0.so.0: cannot open shared object file: No such file or directory

/usr/lib/gimp/2.0/plug-ins/web-page: error while loading shared libraries: libwebkitgtk-1.0.so.0: cannot open shared object file: No such file or directory
This task depends upon

Closed by  Doug Newgard (Scimmia)
Sunday, 10 July 2016, 02:49 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Already an optdep

Loading...