Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#49981 - [freetype2] fonts are too bold with freetype2-2.6.4-2

Attached to Project: Arch Linux
Opened by patrick (potomac) - Thursday, 07 July 2016, 03:52 GMT
Last edited by Doug Newgard (Scimmia) - Thursday, 07 July 2016, 04:55 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 9
Private No

Details

Description: with freetype2-2.6.4-2 there is a bug : fonts are too bold, fonts look terrible, blurry , fatty

hinting seems to no work,

I tried the avalaible settings in /etc/environment :

FT2_SUBPIXEL_HINTING=0 # Classic mode
FT2_SUBPIXEL_HINTING=1 # Infinality mode
FT2_SUBPIXEL_HINTING=2 # Default mode


but it doesn't fix the problem, fonts are still ugly ( too bold, for example in gimp, thunderbird, web sites in firefox ),

with the previous version ( freetype2 2.6.3-1 ) there is no problem


Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:
- update to freetype2-2.6.4-2
- restart your applications
- you will notice that the fonts are too bold
This task depends upon

Closed by  Doug Newgard (Scimmia)
Thursday, 07 July 2016, 04:55 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Configuration issue
Comment by Doug Newgard (Scimmia) - Thursday, 07 July 2016, 04:20 GMT
Which did you try? Did you completely log off and log back in after each change?
Comment by patrick (potomac) - Thursday, 07 July 2016, 04:52 GMT
I did further tests :

after each reboot/log off the bug is still here with these 2 settings :

FT2_SUBPIXEL_HINTING=1 # Infinality mode
FT2_SUBPIXEL_HINTING=2 # Default mode

but with "FT2_SUBPIXEL_HINTING=0" setting it's slightly better after a reboot/logoff, but not 100% identical to freetype2-2.6.3-1, I can detect again a little fat on the fonts,

I notice that freetype archlinux package ( 2.6.4-2 ) uses 3 patches, I wonder if this difference can explain the bug ?

https://git.archlinux.org/svntogit/packages.git/tree/trunk?h=packages/freetype2

I would be interesting to rebuild the package without these patches, the upstream version doesn't seem to have these patches

Loading...