Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#49967 - [geeqie] remove opt dep

Attached to Project: Arch Linux
Opened by mattia (nTia89) - Wednesday, 06 July 2016, 08:59 GMT
Last edited by Doug Newgard (Scimmia) - Wednesday, 06 July 2016, 14:09 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

fbida opt dependency, for the geeqie package, for rotate jpg images is no longer required


Additional info:
* also official website doesn't mention it as opt deps


Steps to reproduce:
inst geeqie in a system without fbida
try to rotate a jpeg image
This task depends upon

Closed by  Doug Newgard (Scimmia)
Wednesday, 06 July 2016, 14:09 GMT
Reason for closing:  Not a bug
Comment by xduugu (xduugu) - Wednesday, 06 July 2016, 09:06 GMT
- Open geeqie in terminal
- Rotate image
- Right click on image, Edit --> Apply the orientation to image content
- Observe terminal output:

$ geeqie
/usr/lib/geeqie/geeqie-rotate: line 23: exiftran: command not found

exiftran is provided by fbida, so it is still an optional dependency.

$ pacman -Fs exiftran
extra/fbida 2.10-2
usr/bin/exiftran
Comment by mattia (nTia89) - Wednesday, 06 July 2016, 11:39 GMT
I've done exactly that operation
and also in a different way e.g. rotate and close (geeqie save it anyhow)

In a few word: 1. geeqie rotate jpeg 2. no output/errors from terminal
Comment by xduugu (xduugu) - Wednesday, 06 July 2016, 12:23 GMT
Maybe you don't see the output, when you close it. (Edit: That's not the reason. See at the bottom.)

But it is definitely listed as requirement in geeqie-rotate [1]:

> This is a helper script that rotate image files according to the metadata
> requirements: ImageMagick, exiftran, exiv2

[1] http://geeqie.org/cgi-bin/gitweb.cgi?p=geeqie.git;a=blob;f=plugins/rotate/geeqie-rotate;hb=HEAD

Edit: You only change the metadata, but not the image itself. If you remove the metadata with exiv2, you should see that the image was not actually rotated. Rotating in geeqie changes the metadata, but you can apply it to the image data, when you use the option "Apply the orientation to image content". For this option, exiftran is required.
Comment by mattia (nTia89) - Wednesday, 06 July 2016, 13:27 GMT
I continue to be not able to reproduce the issue...

I pick up a jpeg photo from my camera, deleted exif content with exiv2 using `exiv2 delete IMG.jpg`
then I rotated it with geeqie. I close it.
I deleted exif data again (but no data was present) and opened it with geeqie that shows me the _rotated_ photo.

Or I haven't understand the problem or I can't reproduce the issue!
Comment by xduugu (xduugu) - Wednesday, 06 July 2016, 13:40 GMT
You have to use another image viewer or delete geeqie's metadata cache at ~/.local/share/geeqie/metadata/ before opening the file again.
Comment by mattia (nTia89) - Wednesday, 06 July 2016, 13:44 GMT
ok, now I understand....

we can close this non-issue
Comment by xduugu (xduugu) - Wednesday, 06 July 2016, 13:46 GMT
Just an addition, because I was wrong. Geeqie doesn't seem to even change the Exif data, when you rotate an image. It's just saved in its metadata storage in .local/share.

- Open file in geeqie, rotate it and exit.
- Open the file in another viewer, e.g. viewnior, and see that is actually was not rotated.
- Open the file again in geeqie. You'll see it rotated. Then right click on the image and choose 'Apply orientation to image content'. Close geeqie.
- Open the file again in another viewer and it is now rotated.

Not the most intuitive workflow for rotating images. ;)

Loading...