Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#49966 - [linux] Hard system freeze with 4.6.3-1-ARCH

Attached to Project: Arch Linux
Opened by Nico Schottelius (telmich) - Wednesday, 06 July 2016, 06:41 GMT
Last edited by Doug Newgard (Scimmia) - Friday, 20 October 2017, 14:50 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 19
Private No

Details

Description:

Since upgrading to 4.6.3-1-ARCH my system freezes hard multiple times per day.
If sounds is being played at the time of freeze, part of the last seconds is continously repeated.

Situation on freeze is that no mouse / keyboard action is being recognised, but screen stays as it is (i.e. xorg screen completely stays). Switching to console is not possible.

I have upgraded linux (4.5.4-1 -> 4.6.3-1), afair 4.5.4 did not have this issue

Additional info:
* package version(s)
* config and/or log files etc.

System running is a Lenovo X1 Carbon (2015):

[15:36] wurzel:~% lspci
00:00.0 Host bridge: Intel Corporation Broadwell-U Host Bridge -OPI (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09)
00:03.0 Audio device: Intel Corporation Broadwell-U Audio Controller (rev 09)
00:14.0 USB controller: Intel Corporation Wildcat Point-LP USB xHCI Controller (rev 03)
00:16.0 Communication controller: Intel Corporation Wildcat Point-LP MEI Controller #1 (rev 03)
00:19.0 Ethernet controller: Intel Corporation Ethernet Connection (3) I218-V (rev 03)
00:1b.0 Audio device: Intel Corporation Wildcat Point-LP High Definition Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #2 (rev e3)
00:1c.1 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #3 (rev e3)
00:1c.5 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #6 (rev e3)
00:1d.0 USB controller: Intel Corporation Wildcat Point-LP USB EHCI Controller (rev 03)
00:1f.0 ISA bridge: Intel Corporation Wildcat Point-LP LPC Controller (rev 03)
00:1f.3 SMBus: Intel Corporation Wildcat Point-LP SMBus Controller (rev 03)
00:1f.6 Signal processing controller: Intel Corporation Wildcat Point-LP Thermal Management Controller (rev 03)
04:00.0 Network controller: Intel Corporation Wireless 7265 (rev 59)
0a:00.0 SATA controller: Samsung Electronics Co Ltd Device a801 (rev 01)
[15:37] wurzel:~%

[15:38] wurzel:~% lsmod
Module Size Used by
fuse 94208 3
hmac 16384 1
drbg 32768 1
ansi_cprng 16384 0
ctr 16384 2
ccm 20480 2
ipt_MASQUERADE 16384 1
nf_nat_masquerade_ipv4 16384 1 ipt_MASQUERADE
iptable_nat 16384 1
nf_conntrack_ipv4 16384 2
nf_defrag_ipv4 16384 1 nf_conntrack_ipv4
nf_nat_ipv4 16384 1 iptable_nat
xt_addrtype 16384 2
iptable_filter 16384 1
xt_conntrack 16384 1
nf_nat 20480 2 nf_nat_ipv4,nf_nat_masquerade_ipv4
nf_conntrack 90112 5 nf_nat,nf_nat_ipv4,xt_conntrack,nf_nat_masquerade_ipv4,nf_conntrack_ipv4
br_netfilter 24576 0
bridge 122880 1 br_netfilter
stp 16384 1 bridge
llc 16384 2 stp,bridge
dm_thin_pool 61440 1
dm_persistent_data 57344 1 dm_thin_pool
dm_bio_prison 16384 1 dm_thin_pool
dm_bufio 24576 1 dm_persistent_data
loop 28672 4
uvcvideo 86016 0
videobuf2_vmalloc 16384 1 uvcvideo
videobuf2_memops 16384 1 videobuf2_vmalloc
videobuf2_v4l2 20480 1 uvcvideo
videobuf2_core 36864 2 uvcvideo,videobuf2_v4l2
videodev 151552 3 uvcvideo,videobuf2_core,videobuf2_v4l2
media 32768 2 uvcvideo,videodev
btusb 40960 0
btrtl 16384 1 btusb
btbcm 16384 1 btusb
btintel 16384 1 btusb
bluetooth 454656 5 btbcm,btrtl,btusb,btintel
joydev 20480 0
mousedev 20480 0
arc4 16384 2
sha256_ssse3 32768 3
sha256_generic 24576 1 sha256_ssse3
nls_iso8859_1 16384 1
nls_cp437 20480 1
vfat 20480 1
fat 65536 1 vfat
iwlmvm 262144 0
mac80211 655360 1 iwlmvm
iwlwifi 184320 1 iwlmvm
mei_wdt 16384 0
iTCO_wdt 16384 0
iTCO_vendor_support 16384 1 iTCO_wdt
cfg80211 495616 3 iwlwifi,mac80211,iwlmvm
msr 16384 0
intel_rapl 20480 0
x86_pkg_temp_thermal 16384 0
intel_powerclamp 16384 0
coretemp 16384 0
kvm_intel 184320 0
kvm 499712 1 kvm_intel
irqbypass 16384 1 kvm
pcspkr 16384 0
input_leds 16384 0
psmouse 122880 0
serio_raw 16384 0
intel_pch_thermal 16384 0
i2c_i801 20480 0
lpc_ich 24576 0
shpchp 32768 0
wmi 20480 0
battery 20480 0
thinkpad_acpi 77824 1
ac 16384 0
nvram 16384 1 thinkpad_acpi
led_class 16384 3 iwlmvm,thinkpad_acpi,input_leds
rfkill 20480 6 cfg80211,thinkpad_acpi,bluetooth
snd_hda_codec_hdmi 45056 1
snd_hda_codec_realtek 69632 1
snd_hda_codec_generic 69632 1 snd_hda_codec_realtek
fjes 28672 0
mei_me 32768 0
e1000e 217088 0
snd_hda_intel 32768 2
snd_hda_codec 106496 4 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_intel
mei 81920 3 mei_wdt,mei_me
tpm_tis 20480 0
tpm 36864 1 tpm_tis
ptp 20480 1 e1000e
pps_core 20480 1 ptp
snd_hda_core 61440 5 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel
snd_hwdep 16384 1 snd_hda_codec
thermal 20480 0
evdev 24576 24
mac_hid 16384 0
processor 32768 0
sch_fq_codel 20480 6
snd_pcm_oss 45056 0
snd_mixer_oss 24576 1 snd_pcm_oss
snd_pcm 86016 6 snd_pcm_oss,snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_hda_core
snd_timer 28672 1 snd_pcm
snd 65536 14 snd_hda_codec_realtek,snd_pcm_oss,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel,thinkpad_acpi,snd_mixer_oss
soundcore 16384 1 snd
drbd 356352 0
lru_cache 16384 1 drbd
libcrc32c 16384 2 drbd,dm_persistent_data
crc32c_generic 16384 0
ip_tables 28672 2 iptable_filter,iptable_nat
x_tables 28672 5 ip_tables,ipt_MASQUERADE,xt_conntrack,iptable_filter,xt_addrtype
ext4 520192 1
crc16 16384 2 ext4,bluetooth
jbd2 90112 1 ext4
mbcache 16384 2 ext4
algif_skcipher 20480 0
af_alg 16384 1 algif_skcipher
dm_crypt 28672 2
dm_mod 102400 10 dm_persistent_data,dm_bufio,dm_crypt,dm_thin_pool
sd_mod 36864 4
crct10dif_pclmul 16384 0
crc32_pclmul 16384 0
atkbd 24576 0
libps2 16384 2 atkbd,psmouse
crc32c_intel 24576 1
ghash_clmulni_intel 16384 0
xhci_pci 16384 0
aesni_intel 167936 11
ehci_pci 16384 0
ahci 36864 3
libahci 28672 1 ahci
aes_x86_64 20480 1 aesni_intel
lrw 16384 1 aesni_intel
ehci_hcd 69632 1 ehci_pci
gf128mul 16384 1 lrw
xhci_hcd 159744 1 xhci_pci
glue_helper 16384 1 aesni_intel
ablk_helper 16384 1 aesni_intel
cryptd 20480 5 ghash_clmulni_intel,aesni_intel,ablk_helper
libata 196608 2 ahci,libahci
scsi_mod 155648 2 libata,sd_mod
usbcore 200704 6 btusb,uvcvideo,ehci_hcd,ehci_pci,xhci_hcd,xhci_pci
usb_common 16384 1 usbcore
i8042 24576 1 libps2
serio 20480 7 serio_raw,atkbd,i8042,psmouse
i915 1204224 5
video 36864 2 i915,thinkpad_acpi
button 16384 1 i915
intel_gtt 20480 1 i915
i2c_algo_bit 16384 1 i915
drm_kms_helper 114688 1 i915
syscopyarea 16384 1 drm_kms_helper
sysfillrect 16384 1 drm_kms_helper
sysimgblt 16384 1 drm_kms_helper
fb_sys_fops 16384 1 drm_kms_helper
drm 294912 6 i915,drm_kms_helper
[15:38] wurzel:~%


Steps to reproduce:

This task depends upon

Closed by  Doug Newgard (Scimmia)
Friday, 20 October 2017, 14:50 GMT
Reason for closing:  Fixed
Additional comments about closing:  OP reports it no longer happens
Comment by Nico Schottelius (telmich) - Wednesday, 06 July 2016, 13:23 GMT
3 freezes so far today - going back to 4.5.4-1-ARCH to error out hardware issues
Comment by Nico Schottelius (telmich) - Thursday, 07 July 2016, 03:13 GMT
No freeze w/ 4.5.4 since my last comment
Comment by Mihuleac Sergiu (physicalit) - Friday, 08 July 2016, 22:05 GMT
I thought i was going crazy :)) Almost broke my laptop, now I'm happy that I'm not the only one experiencing this bug.I'm on the lts kernel now, looks well for the past day, no freeze. Any update on this bug?
Comment by Nico Schottelius (telmich) - Saturday, 09 July 2016, 05:22 GMT
I'm happily back on 4.5.4, now 2 days of uptime. Not sure if it's already known upstream
Comment by Giorgian Borca-Tasciuc (GiorgianB) - Saturday, 09 July 2016, 21:32 GMT
I am also very pleased to find out I am not the only one experiencing this problem. I am running on a Dell XPS 8700, but Arch Linux has been freezing on my desktop since version Linux kernel version ~4.2 (I forget the exact one).
@Nico Schottelius
I think you should attach a log from the system journal. Grep for "(soft lockup|hard lockup|stalls)" in journalctl and see what you have find.
   logs (1.7 KiB)
Comment by Nico Schottelius (telmich) - Sunday, 10 July 2016, 04:08 GMT
Unfortunately there are no matches in journalctl (not surprised though for a hard lockup)
Comment by A Web (aweb) - Monday, 11 July 2016, 17:57 GMT
I have the exact same problem on my Thinkpad T450s with intel graphics. It started happening when I upgraded from 4.5.x to 4.6.x. For now, a workaround is to boot the lts kernel, but of course at some point lts may cross 4.6, and it's already at 4.4, so this is not a long-term solution.
Comment by Seth Barberee (Sesese9) - Wednesday, 13 July 2016, 16:13 GMT
This is happening to me also with this kernel and linux-ck. It has to be somewhere in 4.6.x because I never had this problem in 4.5.x. Hopefully, this gets fixed soon.
Comment by William Gathoye (wget) - Monday, 18 July 2016, 08:12 GMT
Hi guys. Same problem here with linux 4.6.4 on Dell XPS 13 L322x (2013 version).

00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
Intel(R) Core(TM) i7-3537U CPU @ 2.00GHz

The system is freezing on X11, when going back and forth desktop using compositor effects on Plasma for example.

Mouse lagging when moving on the screen.

Downgraded to 4.6.2 no problem so far: lags seem to have disappeared.
Comment by A Web (aweb) - Monday, 18 July 2016, 12:55 GMT
I enabled CSM in my BIOS, even though I'm still booting in UEFI mode, and so far I have not had the problem again. So for other's experiencing this issue, you might try that (or switching from UEFI to Legacy boot mode, though then you have to install grub or some other bootloader as well).

Conversely, if anyone experiences this problem while booting in Legacy BIOS, not UEFI, mode, please mention it here.
Comment by cirrus (cirrus) - Thursday, 21 July 2016, 18:34 GMT
i too experienced this ..Here are some logs which may or may not be relevant
http://cirrus.openshells.org/logs.html | grep -i LOCKUP
i had same experience using linux-ck
since upgrading to 4.6.4-1 and/or 4.6.4-1-ck all is well once more.
(edit) booting with BIOS/MBR
X58 Chipset
ATI open dri
I was convinced this was related to ye olde x58 chipset bug https://www.novell.com/support/kb/doc.php?id=7014344 ofc im no expert.
sometimes i would hard lockup where only hitting power button would get it back up, other occasions i'd lose only ethernet and a simple sudo ip link set dev enp5s0 down && sudo ip link set dev enp5s0 up would suffice.
Comment by Javier Fernández (WyRe) - Monday, 25 July 2016, 07:56 GMT
Could it be happening this bug on 4.6.4 version?
Comment by William Gathoye (wget) - Monday, 25 July 2016, 09:32 GMT
@WyRe Like I explained above, in my situation, I was impacted on 4.6.4 too.

But maybe we are all speaking about 2 different unrelated bugs.
Comment by Javier Fernández (WyRe) - Monday, 25 July 2016, 09:40 GMT
@wget well, my freezes are more arbitraries but I suspect that could be the same issue.

VGA compatible controller: NVIDIA Corporation GK107 [GeForce GT 740] (rev a1)
AMD Athlon(tm) II X4 640 Processor
Comment by Javier Fernández (WyRe) - Wednesday, 27 July 2016, 19:50 GMT
I had this issues even with 4.6.1 version, maybe is not the kernel, but my hardware apparently works fine, in W$ 10 I haven't got this freezes.
Comment by u (u) - Friday, 29 July 2016, 17:33 GMT
I have also been experiencing this issue on a Lenovo X1 Carbon (2015) with a 4.6.* kernel. The hard freeze happens within 1 minute to 2-3 hours after boot, and is easiest to trigger with graphics heavy applications, such as mpv. When the computer freezes, the mouse is irresponsive, the audio gets stuck in a 1 second loop, and it is not possible to kill X or reboot using REISUB, but rather the power button has to be held down.

After reverting back to 4.5.4 the system has not yet suffered any freezes. Current uptime is 9 hours and counting.
Comment by cirrus (cirrus) - Saturday, 06 August 2016, 20:37 GMT
Been having exact same issue as above user (u) with audio loop/freeze/mpv using 4.6.* (and -ck) sometimes after 10 hours + uptime, sometimes straight after boot after x launches. Kernels 4* have been troublesome for me, when i want work done i roll back to linux-3.10.10-1-x86_64 for a few days (that kernel is rock solid on my hw) i have not tried lts as yet. mobo: asus P6T SE
Comment by Paul Jago (Snacksicles) - Sunday, 07 August 2016, 04:10 GMT
I have an Asus UX305F, and I've been getting the crash once a day or so, including WHILE WRITING THIS GODDAMN COMMENT. Kernel is 4.6.4-1-ARCH, lspci attached.
Comment by William Gathoye (wget) - Wednesday, 17 August 2016, 10:36 GMT
Upgraded to kernel 4.7. No problem so far. Hope this will last.
Comment by Calin Cruceru (calincru) - Monday, 29 August 2016, 02:40 GMT
Any other updates for those who experienced this problem with 4.6.*, does it still happen in 4.7.*?
Comment by William Gathoye (wget) - Monday, 29 August 2016, 09:55 GMT
No problem on the 4.7 branch on my side. It seems like the issue disappeared with an update to the 4.6 branch.
Comment by Nico Schottelius (telmich) - Monday, 29 August 2016, 13:32 GMT
I have had a lockup with 4.7.1 - back to 4.5.4-1-ARCH, last known working version.
Comment by Javier Fernández (WyRe) - Thursday, 01 September 2016, 21:32 GMT
I still have this bug even with 4.7.2-1 kernel version.
Comment by Javier Fernández (WyRe) - Thursday, 01 September 2016, 21:41 GMT
These are my pci and modules list.
   lspci (2.4 KiB)
   lsmod (3.6 KiB)
Comment by Victor Baumann (smoe) - Friday, 02 September 2016, 17:07 GMT
I also still have the problem with 4.7.1 and 4.7.2 on my Dell XPS 13 9343.

I suspect that it is somehow related to audio. If my memory doesn't betray me, I never had my system freeze when not playing audio. But it crashed everywhere between couple of minutes and hours when using one of mpd, cmus, spotify or playing videos in firefox or chromium.

alsa-info.sh yields
cat: /sys/module/snd_soc_sst_broadwell/parameters/*: No such file or directory

Output can be found here
http://www.alsa-project.org/db/?f=5ba0985657ed63f7ffe72f2fe8f93d8258cd3018
Comment by Javier Fernández (WyRe) - Saturday, 03 September 2016, 17:00 GMT
Yes, I think the same, maybe could it be audio or video.
Comment by Lily (voidlily) - Thursday, 22 September 2016, 00:57 GMT
I had a similar issue under linux-ck-4.7.4-1. The last known working version for me is linux-ck-4.6.5-3, as I previously had over a month uptime on that kernel. I have since downgraded to that version.

Attached are my lspci, lsmod, and alsa-info.sh outputs on 4.6.5-3-ck.

Edit: Additionally, I was unable to find any useful information being logged from freezes on 4.7.4-1-ck. I checked journalctl, old /var/log/messages.log.1, /var/log/Xorg.0.log.old, and coredumpctl.
Comment by Douglas Browne (Xenograph) - Thursday, 13 October 2016, 21:12 GMT
Having the same issue on my Dell XPS 13 9343 (Intel 7265 wifi). Currently on 4.7.6-1, but I've been having this since August on 4.6.x I believe. I did a fresh install and incrementally reinstalled extras, the problem disappeared for a few weeks, then appeared back. I think it may have started happening again around when I installed PulseAudio. Will remove PulseAudio and stop doing anything audio related and see if that changes anything.
Comment by Davis Forquer (d.forquer) - Friday, 21 October 2016, 10:18 GMT
I had the same issue, but starting from 4.8.2 kernel I do not observe it anymore.
Comment by William Gathoye (wget) - Friday, 21 October 2016, 10:32 GMT
I can confirm d.forquer's assumptions. I updated again to the current kernel branch and haven't any issue since 4.8.2. As a reminder, I switched back to the 4.4 LTS branch due to these graphics crashes/instabilities on Dell XPS 13 L322x (2013 version).
Comment by Douglas Browne (Xenograph) - Monday, 24 October 2016, 20:30 GMT
I'm still experiencing the issue on 4.8.3-1.
Comment by Calin Cruceru (calincru) - Monday, 24 October 2016, 20:32 GMT
Me too. I reverted to 4.5.4-1-ARCH.
Comment by oomph (socrat) - Thursday, 03 November 2016, 00:59 GMT
I've had this happening to me since the upgrade to 4.6.1 now 4 months later im still on the lts kernel with last trying 4.8.1.
However my system would freeze on boot with no error message displayed,its just stuck forever.
i5 cpu amd7xxxm vga opendrivers.
Comment by Solano Felício (solano) - Sunday, 13 November 2016, 16:54 GMT
I've had this exact problem since August (hard lock, unable to enter the ttys, audio looping), but the random freezes happened about once a week. From the logs, first I blamed xscreensaver, then NetworkManager, but they both seem innocent after investigation (system freezes even when they are not active). With the upgrade to 4.8.7 last Thursday, my system started to freeze every 2~5h, so I downgraded to 4.8.6. Since then, I've had no issues. I expect it to happen again in a week at most, though.
Comment by oomph (socrat) - Sunday, 13 November 2016, 19:41 GMT
I've traced this back to a kernel commit since 4.6 and a kernel bug has already been submitted, lets wait for the fix now.
https://bugzilla.kernel.org/show_bug.cgi?id=141741
Comment by Lukas K. (luk4s) - Wednesday, 16 November 2016, 00:00 GMT
How is that bug related to this issue?
Comment by Michael Langston (melangston) - Sunday, 18 December 2016, 13:53 GMT
I had the same hard-freeze with audio looping. It typically occurred using mpd but happened once on youtube. Through trial-and-error I found it only happened connected via wifi. rolling back my Centrino wireless-N 6200's firmware solved it for me so far (a couple days now). Prior firmware versions can be found on Intel's iwlwifi website. I hope this helps.
Comment by William Gathoye (wget) - Sunday, 18 December 2016, 16:21 GMT
Thanks for your comment Michael. This will help us narrow the issue. On my Dell XPS 13 (2013), I have a Centrino Advanced-N 6235 and I remember the kernel module has crashed several times lately. I had to get back on the 4.4 LTS branch to solve that issue (and the hard freeze issue as well). But I don't know if the problem can be caused by the Wireless kernel module. Let see if others report the same issue. According my friends who are on the 4.8 branch and on other GNU/Linux distribution like Gentoo Linux, the 4.8 branch is reported not so stable. Gentoo thinks to hide it from the stable repos. This is the second huge issue I have this year with Arch Linux and the second time getting back to the LTS branch helped me to solve an issue. I recommend you to switch to that older but more stable branch as well.
Comment by Michael Langston (melangston) - Wednesday, 28 December 2016, 15:37 GMT
My music server has now frozen with both the older iwlwifi but using the current kernel, though it lasted several days. This morning it just froze running the LTS kernel and the current iwlwifi firmware.
Comment by Lily (voidlily) - Wednesday, 28 December 2016, 21:26 GMT
The machine I had freezing issues with ( https://bugs.archlinux.org/task/49966#comment151167 ) doesn't have wifi so I'd think that there's another cause in addition to the iwlwifi issue.
Comment by Calin Cruceru (calincru) - Saturday, 07 January 2017, 11:17 GMT
Is this solved in 4.9?
Comment by Nico Schottelius (telmich) - Saturday, 07 January 2017, 12:50 GMT
Not sure - I switched to a newer gen4 thinkpad x1 carbon, but haven't seen a freeze in 4.8 anymore for some time.
Comment by oomph (socrat) - Saturday, 07 January 2017, 19:05 GMT
4.9 will try something similar so a similar bug might happen with radeon driver.
Keep 4.8.13 in backup before you upgrade to 4.9
Comment by Lukas K. (luk4s) - Thursday, 12 January 2017, 22:12 GMT
I tried enabling the CSM while still booting using UEFI, and I still got the occasional freeze on 4.8.13. Is anyone experiencing this issue when booting BIOS-style?
Comment by Robert (ristic) - Thursday, 02 February 2017, 00:47 GMT
I have an HP EliteBook 820 with a 5th Generation Intel Core i7-5600U 2.6 GHz (max turbo frequency 3.2-GHz), 4 MB L3 Cache, 15W. Here are some more details if need be: https://robsco.info/articles/hp_elitebook_820_g2/

I am noticing the same or a similar issue. Running the current kernel ('linux' package) I have this same freeze. Audio loops (roughly 1 sec). Keyboard is not responsive although I can adjust the keyboard backlight but from what I understand this is operating at a lower level. The OS does not see the keyboard events for a keyboard backlight brightness change with this particular laptop. It has happened when no audio is playing but that is much more rare. It makes me think this could be a pulseaudio related issue in relation to the kernel.

I am currently on kernel 4.9.6-1-ARCH. My machine does not go longer than roughly 3 days before it encounters a freeze. Most of the time it will freeze once a day, most of the time when audio is playing. When I run the LTS kernel ('linux-lts' package), I do not encounter any freezes but I do have other issues such as wifi problems (I believe driver related) and I can't run a low JACK buffer size for some reason. I'm going to see what I can do to get the LTS kernel working for me as it seems to be the only real solution at this stage.

More potentially relevant info:
I am using TLP with all of the default settings (from what I can remember).
I run pulseaudio all of the time.
I have "threadirqs" and "rw" kernel parameters set.
I am using legacy boot - BIOS.

I even went as far as replacing the RAM in this laptop as I thought that could be the issue. I had an issue with bad RAM in a previous desktop of mine that resulted in a similar issue.
Comment by Lukas K. (luk4s) - Thursday, 02 February 2017, 18:24 GMT
Has anyone experienced the "hard freeze" issue on a core i5? Maybe this issue is specific to the core i7.
Comment by Lily (voidlily) - Tuesday, 07 March 2017, 21:54 GMT
Has anyone experienced this issue on 4.9.11 or 4.10.1?
Comment by Douglas Browne (Xenograph) - Wednesday, 08 March 2017, 00:55 GMT
@Lukas K. (luk4s): I have the issue with an i5. Haven't tested with 4.9/10.
Comment by Victor Baumann (smoe) - Friday, 10 March 2017, 13:27 GMT
I updated my Dell XPS 13 9343 yesterday to 4.9.11 and linux-firmware-20170227.5abb924-1 and so far no problems after 24h uptime. But i had times before where I didn't encounter a freeze for a couple of days. I'll keep the laptop running over the weekend and give you an update on Monday.
Comment by Victor Baumann (smoe) - Monday, 13 March 2017, 13:52 GMT
Had another freeze Sunday to Monday night with 4.9.11. Appeared to be the same type of freeze as previously in terms of not reacting to any input and no entries in the journal, but there was no audio looping anymore.

Don't know if its helpful but i attach a list of the programs (according to ps_mem) that were running at the time.

Trying out linux-4.10.1-1 now.
Comment by Victor Baumann (smoe) - Wednesday, 15 March 2017, 13:47 GMT
Had two freezes on 4.10.1 since Monday. Went back to 4.4.
Comment by Lukas K. (luk4s) - Wednesday, 15 March 2017, 18:08 GMT
Since this issue doesn't seem to go away by itself and no one has access to an XDP debugger, someone really needs to bisect 4.5.4 to 4.6.
Comment by Robert (ristic) - Tuesday, 21 March 2017, 20:32 GMT
I am still experiencing these freezes every now and then.

I wonder if it could be related to the way Arch configures the kernel? Are there reports of this sort of behaviour from other distributions? I tried a search but didn't find all that much.

I want to try out Debian Testing at some stage to see if this same issue presents itself.
Comment by Robert (ristic) - Thursday, 20 April 2017, 00:37 GMT
Just thought I'd add some feedback here. The "linux-rt-lts" kernel from the AUR has been working well for me thus far:

$ uname -a
Linux tiny 4.4.53-rt66-1-rt-lts #1 SMP PREEMPT RT Fri Mar 31 16:51:29 CST 2017 x

$ uptime
19:33:29 up 13 days, 5:57, 6 users, load average: 0.72, 0.55, 0.45

This is with about 5 to 10 hours of use (not suspended) time each day.
Comment by Lukas K. (luk4s) - Thursday, 20 April 2017, 01:16 GMT
That's not surprising since it's a 4.4 kernel. Currently, I'm running 4.6.0 from the kernel git and haven't experienced any lockups so far. After an uptime of a week or so, I'll switch to 4.7 to start bisecting.
Comment by Lily (voidlily) - Thursday, 20 April 2017, 01:26 GMT
I've been running 4.6.5-ck and haven't had any issues, so I suspect we should bisect in the 4.7 series (I had issues at 4.7.4-ck and rolled back)

 uname -a
Linux homu 4.6.5-3-ck #1 SMP PREEMPT Fri Aug 5 18:07:16 EDT 2016 x86_64 GNU/Linux

 uptime
18:26:12 up 98 days, 18:41, 13 users, load average: 10.52, 10.94, 10.80
Comment by Lukas K. (luk4s) - Tuesday, 02 May 2017, 00:34 GMT
Am I the only one bisecting the kernel right now? Since the freeze is rather hard to reproduce, this is a very time-consuming process. I'd be glad if some other people in here would start bisecting as well to speed things up. I'm using the vanilla kernel from kernel.org and marked v4.6 as good and v4.7 as bad.
Comment by Lukas K. (luk4s) - Sunday, 14 May 2017, 15:30 GMT
Another idea: Maybe this is related to the vboxdrv module? I'm constantly running a VM in VirtualBox. What are the rest of you doing to deal with this serious issue?
Comment by Lily (voidlily) - Sunday, 14 May 2017, 19:26 GMT
I also have the vboxdrv module loaded but I haven't actually used virtualbox in a long time (switched to kvm). The wiki mentions freezes related to either broadwell, SMAP, or version related. I might try testing by removing virtualbox packages then upgrading. Great find!
Comment by Douglas Browne (Xenograph) - Sunday, 14 May 2017, 20:44 GMT
I do not have the vboxdrv module or any virtualbox package installed on my machine.
Comment by ice1e0 (ice1e0) - Saturday, 20 May 2017, 08:04 GMT
I had probably the same problem. I had 4.10.* installed, downgraded to 4.9 and 4.4 (AUR linux-lts44). Did not helped.

After a while discovering i found help in https://wiki.archlinux.org/index.php/Intel_graphics#X_freeze.2Fcrash_with_intel_driver

I added 'Option "DRI" "False"' to /etc/X11/xorg.conf.d/20-intel.conf which solved the problem. Hope that helps.

insights:
* Hardware: ThinkPad T540p
* current kernel: 4.4.67-1-lts44
* output of lspci | grep VGA is:
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)

p.s. I found that bug thread a bit confusing. Many people with different hardware wrote here and gave their insights ; and said already that it worked for them, but the bug thread is still open. Probably a new bug thread for each case with a 'similar to' link would be more helpful.

[EDIT 27.06.17] Did not helped, see comment below.
Comment by piernov (piernov) - Tuesday, 27 June 2017, 08:42 GMT
I'm having a similar issue on a desktop Skylake machine. However it has got an Intel ES CPU on an Asus Z170P D3 motherboard, so it's probably part of the issue.
It freezes randomly on 4.9, after a couple of hours to a day or two. Sometimes I see a kernel panic "kernel NULL pointer dereference".
It was working perfeclty fine on 4.4.62. I recently upgraded to 4.4.73 (machine rebooted after failure of one HDD) and it's showing the same behaviour as 4.9. So I went back to 4.1.41 and it seems OK so far.
This machine is used as a home server so it runs 24/7 with light workload. The integrated GPU is still activated and the X server is started even though it's not used.
I did not try to disable HyperThreading. As far as I remember, I did try using a dedicated graphics card and the issue was the same.

Can someone confirm it broke again between 4.4.62 and 4.4.73?
Comment by ice1e0 (ice1e0) - Tuesday, 27 June 2017, 22:07 GMT
Just a short update from me:
I still use the 4.4.71 (AUR linux-lts44). Unfortunately I had some freezes, so the described trick with DRI seems not to be the solution. But the number of system freezes decreased.

I have a Haswell processor with activated hyperthreading (Intel(R) Core(TM) i7-4710MQ CPU @ 2.50GHz). So I guess that I am not part of this bug with Skylake/Kaby Lake - https://lists.debian.org/debian-devel/2017/06/msg00308.html
Comment by piernov (piernov) - Sunday, 02 July 2017, 22:14 GMT
Tried disabling HyperThreading and booting with 4.11.7: froze after 4 hours.
The only stable branch for me right now is LTS 4.1.
Comment by piernov (piernov) - Sunday, 16 July 2017, 18:58 GMT
Freezed after 24 hours on 4.12.1. I had disabled C-States and other power management features, as well as VT-d.
I'm going to try running on 4.4.68.
Comment by russell (russell) - Tuesday, 25 July 2017, 13:22 GMT
Experiencing this also using Kernel 4.11.9-1-Arch.

CPU: AMD A10-7850K
GPU: AMD Radeon HD 6950

See attached output for lspci, lsmod, alsa-info and pacman -Q.
Comment by Nico Schottelius (telmich) - Tuesday, 15 August 2017, 17:25 GMT
I think this might be outdated - at least from my side.
Comment by u (u) - Tuesday, 15 August 2017, 18:19 GMT
> I think this might be outdated - at least from my side.

Nico,

Just to make sure I understood you correctly. Have you been experiencing crashes on your hardware before, and with the latest kernel those are no longer happening?

What hardware are you running on (and which version of the kernel).

Cheers /u
Comment by Nico Schottelius (telmich) - Tuesday, 15 August 2017, 18:53 GMT
That is perfectly correct understood.

I am running 4.11.9-1 on the affected machine and it is stable now for some months - sorry for the late update!
Comment by u (u) - Tuesday, 15 August 2017, 19:22 GMT
Thanks! I'll give it a try later with my x1.
Comment by Lukas K. (luk4s) - Thursday, 21 September 2017, 23:33 GMT
I recently ran 4.12 for some time (a week or so) while not listening to music. When i started listing to music again, the freezes started to happen again. So maybe this issue is related to audio?
Comment by mattia (nTia89) - Tuesday, 03 October 2017, 19:57 GMT
faulty sound card?
not so unlikely... https://bugzilla.kernel.org/show_bug.cgi?id=118051#c15

Loading...