Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#49930 - [gpa] gnupg-2.1.13-1 breaks gpa key signing and setting key trust

Attached to Project: Community Packages
Opened by Darrell Ostrom (0strodamus) - Sunday, 03 July 2016, 20:06 GMT
Last edited by Doug Newgard (Scimmia) - Saturday, 03 December 2016, 05:57 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To speps (archspeps)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: gnupg-2.1.13-1 breaks gpa key signing and setting key trust


Additional info:
* gnupg-2.1.13-1 and gpa-0.9.9-2
* using default settings provided by gnupg and gpa with a single secret key imported and set to default via gpa settings

Steps to reproduce 1:

a) launch gpa
b) right-click any key in the keyring and select "Set Owner Trust..."
c) change the trust value to a different value and click ok

error produced:

The GPGME library returned an unexpected
error at gpakeytrustop.c:217. The error was:

General error

This is either an installation problem or a bug in GPA.
GPA will now try to recover from this error.

Steps to reproduce 2:

a) launch gpa
b) right-click any key in the keyring and select "Sign Keys..."
c) click yes

error produced:

The GPGME library returned an unexpected
error at gpakeysignop.c:257. The error was:

General error

This is either an installation problem or a bug in GPA.
GPA will now try to recover from this error.

If I downgrade to gnupg-2.1.12-2, gpa stops throwing error messages and works as normal.

I also suspect that the problems signing packages described in this forum post are also caused by gnupg-2.1.13-1. https://bbs.archlinux.org/viewtopic.php?id=214338
I am also having issues signing packages consistently and repeatedly using gnupg-2.1.13-1. If I downgrade to gnupg-2.1.12-2 all of the package signing issues go away.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Saturday, 03 December 2016, 05:57 GMT
Reason for closing:  Fixed
Additional comments about closing:  gpa 0.9.10-1
Comment by Darrell Ostrom (0strodamus) - Thursday, 07 July 2016, 20:33 GMT
I compiled gpa with the upstream fix at https://github.com/gpg/gpa/commit/b9efe75ab7addb2eecd8e2274ed8907b9f6a3712 and gpa is now signing and setting trust on keys successfully. At gpa launch, "Libgcrypt warning: missing initialization" errors are generated by gpg-connect-agent and gpgconf, but the application is working. In hindsight, I should have opened this bug report for gpa. Sorry for any inconvenience this may have caused.

Loading...