Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#49916 - [passenger] PKGBUILD does not use recommended source

Attached to Project: Community Packages
Opened by Ista Zahn (izahn) - Saturday, 02 July 2016, 15:51 GMT
Last edited by Sergej Pupykin (sergej) - Monday, 04 July 2016, 13:18 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: My RoR app was failing with error message

cannot load such file -- /usr/lib/passenger/src/ruby_supportlib/phusion_passenger/vendor/union_station_hooks_core/lib/union_station_hooks_core (LoadError)

I asked on the passenger mailing list[1] and was told not to use the tarballs from github, but rather the ones from https://www.phusionpassenger.com/download. I modified the PKGBUILD file to download from the recommended source and rebuilt and installed the package. My application then ran correctly, so I think the official PKGBUILD should use the recommended source.

I have attached the PKGBUILD modified to use the recommended source.

Additional info:
* package version(s)
passenger 5.0.29

Steps to reproduce:
1. Install the passenger package with `pacman -S passenger`
2. Configure apache as instructed
3. Download and set up https://github.com/ivaldi/brimir
3. Visit the app in a browser

[1] https://groups.google.com/forum/?utm_medium=email&utm_source=footer#!msg/phusion-passenger/gqgpn7aTGA0/auPm4HuVBgAJ
   PKGBUILD (0.9 KiB)
This task depends upon

Closed by  Sergej Pupykin (sergej)
Monday, 04 July 2016, 13:18 GMT
Reason for closing:  Fixed
Additional comments about closing:  thank you

Loading...