Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#49893 - [gvfs] gvfs-mount does not show all of devices that can be mounted. As result Thunar doesn't show.

Attached to Project: Arch Linux
Opened by elfrock (elfrock) - Thursday, 30 June 2016, 17:55 GMT
Last edited by Doug Newgard (Scimmia) - Tuesday, 20 September 2016, 02:14 GMT
Task Type Bug Report
Category Packages: Extra
Status Assigned   Reopened
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Description:
In XFCE4.12 system with Thunar and GVFS with GVFS-afc there is a problem with detection of posible mount points by GVFS.
As result mount points doesn't show at Thunar as devices on the left panel.
Although mount points are not shown, they can be mounted by manual enter address at address field.
That problem I have when I connect my iphone by usb. Usually then I do it Thunar shows 2 different devices possible to mount: "Documents" and "Iphone".
After reinstall of system (full fresh installation) Thunar shows only one possible mount point "Documents".
If check GVFS output of possible mounts in terminal (nothing mounts only hdd) with command "gvfs-mount --list" can be seen only HDD mount point and "Documents" mount point.
So as I think thats the reason of Thunar device list. Thunar doesn't show anything else.

Mount point "Documents" have mount address: afc://0d6bdd61342106d5e21144d4e2a64c547ccfaa21:3/ (serial number of device)
If enter in address field afc://0d6bdd61342106d5e21144d4e2a64c547ccfaa21/
thunar will mount other mount point "Media"
But the problem that although "Media" mount point uses by Rhythmbox and Banshee for sync media with Iphone, Media Players doesn't see any device for syncing.
As I think because there isn't that mount point at GVFS.

Additional info:
* package version(s)
- gvfs-1.28.2-1
- gvfs-afc-1.28.2-1
- libimobiledevice-1.2.0-3
- libusbmuxd-1.0.10-1
- libplist-1.12-4
- usbmuxd-1.1.0-2
- ifuse-1.1.3-3
- libgpod-0.8.3-4

* config and/or log files etc.
Output of GVFS:
$ gvfs-mount --list
Drive(0): Hitachi HTS545025B9SA02
Type: GProxyDrive (GProxyVolumeMonitorUDisks2)
Volume(0): DataDisk
Type: GProxyVolume (GProxyVolumeMonitorUDisks2)
Mount(0): DataDisk -> file:///home/elfrock/DataDisk
Type: GProxyMount (GProxyVolumeMonitorUDisks2)
Volume(0): Documents at iPhone Elfrock
Type: GProxyVolume (GProxyVolumeMonitorAfc)


Steps to reproduce:
- Plugin iphone
- gvfs-mount --list (in terminal)
This task depends upon

Comment by elfrock (elfrock) - Tuesday, 05 July 2016, 18:35 GMT
Downgrading of gvfs and gvfs-afc to version 1.26.3-1 solved the problem.
Now output
$ gvfs-mount --list

Volume(0): iPhone Elfrock
Type: GProxyVolume (GProxyVolumeMonitorAfc)
Mount(0): iPhone Elfrock -> afc://0d6bdd61342106d5e21144d4e2a64c547ccfaa21/
Type: GProxyShadowMount (GProxyVolumeMonitorAfc)
Volume(1): Documents at iPhone Elfrock
Type: GProxyVolume (GProxyVolumeMonitorAfc)
Mount(1): iPhone Elfrock -> afc://0d6bdd61342106d5e21144d4e2a64c547ccfaa21/
Type: GDaemonMount

and now I have mount point to Media folder and Rhythmbox and Banshee sync without any problem.
Comment by Jan de Groot (JGC) - Friday, 05 August 2016, 09:12 GMT
Should be fixed with 1.28.2+22+g6c1124d-1
Comment by elfrock (elfrock) - Tuesday, 20 September 2016, 02:14 GMT
  • Field changed: Percent Complete (100% → 0%)
1.28.3 does not work.
Same problem.

Loading...