Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#49889 - [namcap] Recognize /usr/src as a standard directory

Attached to Project: Arch Linux
Opened by Andrey Vihrov (andreyv) - Wednesday, 29 June 2016, 16:31 GMT
Last edited by Doug Newgard (Scimmia) - Tuesday, 06 December 2016, 15:13 GMT
Task Type Feature Request
Category Arch Projects
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Please consider adding /usr/src to the list of known directories. It is used for kernel module sources, e.g., DKMS-based packages (https://www.archlinux.org/packages/?q=-dkms). Also it can contain vendor-shipped binary ELF files (as in nvidia-dkms).

See also: https://wiki.archlinux.org/index.php/Dynamic_Kernel_Module_Support#namcap_output

Additional info:
* namcap 3.2.7-1

Steps to reproduce:
> namcap nvidia-dkms-367.27-1-x86_64.pkg.tar.xz
nvidia-dkms W: File (usr/src/) exists in a non-standard directory.

nvidia-dkms E: ELF file ('usr/src/nvidia-367.27/nvidia/nv-kernel.o_binary') outside of a valid path.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Tuesday, 06 December 2016, 15:13 GMT
Reason for closing:  Fixed
Comment by Kyle Keen (keenerd) - Friday, 15 July 2016, 21:31 GMT
As a note: http://refspecs.linuxfoundation.org/FHS_3.0/fhs-3.0.html#usrsrcSourceCode

But you are still going to get errors from namcap after I fix this bug. Because it is for "source code reference" any binary files such as nv-kernel.o_binary will generate an error.
Comment by Kyle Keen (keenerd) - Thursday, 21 July 2016, 11:54 GMT
Fixed in commit 005277b.
Comment by Andrey Vihrov (andreyv) - Thursday, 11 August 2016, 08:28 GMT
Thanks, this sounds sane. For my own, similar package I just moved the binary object file to /usr/lib/${pkgname}.

Loading...