Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#49842 - [chromium] browser process hangs when the 'view site information' on the address bar is clicked

Attached to Project: Arch Linux
Opened by Alif (alive4ever) - Saturday, 25 June 2016, 13:32 GMT
Last edited by Doug Newgard (Scimmia) - Sunday, 26 June 2016, 14:42 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Bartłomiej Piotrowski (Barthalion)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
When any webpage is loaded, clicking the 'view site information' on the address bar makes the browser hangs , i.e. not responding to any input and not refreshing the display.

Additional info:
* chromium 51.0.2704.103-1
* under plasma-desktop 5.6.5-1 X session (x86_64)


Steps to reproduce:
Navigate to any webpage, for example 'https://www.archlinux.org'
Click on the green padlock button on the address bar to view site information, such as what is allowed and what is blocked.
The browser process hangs afterwards.

This also happens with plain http sites.

To recover from the hang state, the following command is needed: 'pkill -TERM chromium'.

This task depends upon

Closed by  Doug Newgard (Scimmia)
Sunday, 26 June 2016, 14:42 GMT
Reason for closing:  Not a bug
Comment by Alif (alive4ever) - Saturday, 25 June 2016, 13:42 GMT
This behavior also happens on Gnome (gnome-shell 3.20.2-1).

I've also tried starting chromium in a clean state, by moving the config directory ~/.config/chromium to ~/.config/chromium.orig

Let's see if anybody have the same issue.
Comment by Doug Newgard (Scimmia) - Saturday, 25 June 2016, 17:03 GMT
Anything in the logs? ~/.xsession-errors?
Comment by Alif (alive4ever) - Sunday, 26 June 2016, 03:23 GMT
Here is some journalctl log when chromium hangs (on plasma-desktop)

Jun 26 10:20:13 alive-pc plasmashell[2094]: trying to show an empty dialog
Jun 26 10:20:22 alive-pc kwin_x11[2069]: QXcbConnection: XCB error: 3 (BadWindow), sequence: 19626, resource id: 16777216, major code: 18 (ChangeProperty), minor code: 0
Jun 26 10:20:22 alive-pc kwin_x11[2069]: QXcbConnection: XCB error: 3 (BadWindow), sequence: 19630, resource id: 16777217, major code: 18 (ChangeProperty), minor code: 0
Jun 26 10:20:22 alive-pc plasmashell[2094]: no winId: probably startup task
Jun 26 10:20:39 alive-pc plasmashell[2094]: QXcbConnection: XCB error: 2 (BadValue), sequence: 30249, resource id: 4194310, major code: 142 (Unknown), minor code: 3
Jun 26 10:20:39 alive-pc plasmashell[2094]: QXcbConnection: XCB error: 2 (BadValue), sequence: 30270, resource id: 94371908, major code: 142 (Unknown), minor code: 3
Jun 26 10:22:06 alive-pc kwin_x11[2069]: QXcbConnection: XCB error: 3 (BadWindow), sequence: 14890, resource id: 27339161, major code: 20 (GetProperty), minor code: 0


Comment by Alif (alive4ever) - Sunday, 26 June 2016, 03:34 GMT
Here is some console log when chromium hangs on fvwm session
[9135:9135:0626/102843:ERROR:zygote_communication_linux.cc(392)] Failed to send GetTerminationStatus message to zygote
[9135:9135:0626/102843:ERROR:zygote_communication_linux.cc(392)] Failed to send GetTerminationStatus message to zygote
[9135:9135:0626/102843:ERROR:zygote_communication_linux.cc(392)] Failed to send GetTerminationStatus message to zygote
[9135:9135:0626/102843:ERROR:child_process_launcher.cc(505)] Failed to launch child process

Another log
[9871:10108:0626/103314:ERROR:get_updates_processor.cc(250)] PostClientToServerMessage() failed during GetUpdates
Comment by Alif (alive4ever) - Sunday, 26 June 2016, 03:44 GMT Comment by Alif (alive4ever) - Sunday, 26 June 2016, 03:47 GMT
xsession-errors

fvwm][GetWindowSizeHints]: <<WARNING>> reason: 2: The hints have been ignored because the window's current size would have become invalid. The new hints will become active when the window generates the next ConfigureRequest.

[fvwm][GetWindowSizeHints]: <<WARNING>> reason: 4: The hints have been ignored because the window's current size would have become invalid. The new hints will become active when the window generates the next ConfigureRequest.

[fvwm][GetWindowSizeHints]: <<WARNING>> reason: 2: The hints have been ignored because the window's current size would have become invalid. The new hints will become active when the window generates the next ConfigureRequest.

[fvwm][GetWindowSizeHints]: <<WARNING>> reason: 4: The hints have been ignored because the window's current size would have become invalid. The new hints will become active when the window generates the next ConfigureRequest.

Comment by Alif (alive4ever) - Sunday, 26 June 2016, 09:22 GMT
It seems that the hanging state is when chromium waits for kde wallet to prompt for gpg passphrase. When I restarted and switch to fluxbox from the login manager, this problem doesn't happen anymore.

I switched to KDE after restart and the browser hangs problem is disappeared.

Loading...