Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#49778 - [lxc] lxc-checkconfig incorrect status for "Multiple /dev/pts instances"

Attached to Project: Community Packages
Opened by Alexandru Moise (AlexanderMoses) - Monday, 20 June 2016, 14:03 GMT
Last edited by Sergej Pupykin (sergej) - Friday, 02 December 2016, 15:47 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
In recent kernels (from 4.7-rc2) the config option "CONFIG_DEVPTS_MULTIPLE_INSTANCES" is no longer existent due to the fact that each devpts mount is now an independent filesystem.
A patch has also been submitted to kernel.org for removal of all instances of this config:
https://lkml.org/lkml/2016/6/20/196

Additional info:
lxc version:
lxc-1:2.0.1-1

$ uname -r
4.7.0-rc4-ARCH-00038-gfdfec6b
$ lxc-checkconfig | grep pts
Multiple /dev/pts instances: missing

Steps to reproduce:
1. Boot a kernel newer than 4.7-rc1
2. Run lxc-checkconfig
This task depends upon

Closed by  Sergej Pupykin (sergej)
Friday, 02 December 2016, 15:47 GMT
Reason for closing:  Fixed
Additional comments about closing:  also latest version reports nothing about pts.
Comment by Doug Newgard (Scimmia) - Monday, 20 June 2016, 14:40 GMT
Sounds harmless. And an upstream issue, not a packaging issue.
Comment by Alexandru Moise (AlexanderMoses) - Monday, 20 June 2016, 15:03 GMT
Should at least be kept on the bug tracker so the issue is documented.
Comment by Doug Newgard (Scimmia) - Monday, 20 June 2016, 15:08 GMT
That's up to the maintainer. Personally, I would close it as "upstream"

Report it to them if you want it fixed.
Comment by Alexandru Moise (AlexanderMoses) - Monday, 20 June 2016, 15:38 GMT
Alright then, you can close it.

Loading...