Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#49775 - [docbook-utils] Replace 'nsgmls' calls with 'onsgmls'

Attached to Project: Arch Linux
Opened by Rafael Fontenelle (josephg) - Sunday, 19 June 2016, 23:48 GMT
Last edited by Andreas Radke (AndyRTR) - Wednesday, 22 June 2016, 14:29 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
'docbook-utils' expects jade's `nsgmls' binary to be available in the system, as can be seen in `bin/sgmldiff', `doc/man/Makefile' etc. 'openjade' depends on 'opensp', which provides `onsgmls'. Since 'docbook-utils' depends on 'openjade' and 'openjade' conflicts with 'jade', it would be better to replace nsgmls calls by onsgmls.

Some of the consequences of having nsgmls calls in docbook-utils are: `/usr/bin/sgmldiff' won't be able to parse SGML files (therefore, it won't work) and `backends/man' will fail when calling `nsgmls'.

Additional info:
* package version(s)
docbook-utils 0.6.14
opensp 1.5.2-5
openjade 1.3.2-4
jade 1.2.1-10

* config and/or log files etc.

fwupd's package() log attached shows error message "nsgmls: command not found" by /usr/share/sgml/docbook/utils-0.6.14/backends/man

Steps to reproduce:
- sgmlsdiff file1.sgml file2.sgml
- docbook2man file.sgml
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Wednesday, 22 June 2016, 14:29 GMT
Reason for closing:  Fixed
Comment by Andreas Radke (AndyRTR) - Monday, 20 June 2016, 17:42 GMT
Makes sense. Looking at BLFS they add much simpler fix to opensp: a symlink :)

http://www.linuxfromscratch.org/blfs/view/7.8/pst/opensp.html

They add a lot more symlinks to make it compatible to jade. I guess we should add all symlinks there and make it also conflict with jade. This should allow us to fully replace jade.
Comment by Rafael Fontenelle (josephg) - Monday, 20 June 2016, 17:49 GMT
Indeed, much better use symlinks.
Comment by Andreas Radke (AndyRTR) - Monday, 20 June 2016, 19:59 GMT
Please test opensp 1.5.2-6 in testing repo.
Comment by Rafael Fontenelle (josephg) - Monday, 20 June 2016, 20:34 GMT
You can't set opensp to conflict with jade when openjade provides jade, otherwise opensp will try to remove openjade to solve such conflicts. I think you have to choose one between opensp conflicts and openjade provides or, maybe, unify opensp and openjade in one package.
Comment by Andreas Radke (AndyRTR) - Tuesday, 21 June 2016, 19:44 GMT
Should be fixed now opensp 1.5.2-7 and jade 1.2.1-12. Initial bug should now be solved.

On the long way we can try to fully drop jade and build everything with openjade. But this is another task.
Comment by Rafael Fontenelle (josephg) - Tuesday, 21 June 2016, 20:59 GMT
Yep, it's fixed. Thanks for your support.

Loading...