Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#49765 - [docbook-utils] Replace openjade with jade

Attached to Project: Arch Linux
Opened by Rafael Fontenelle (josephg) - Sunday, 19 June 2016, 01:37 GMT
Last edited by Andreas Radke (AndyRTR) - Sunday, 19 June 2016, 19:32 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
'jade' is set to replace 'openjade', and 'docbook-utils' currently has 'openjade' as dependency.

Additional info:
* package version(s)
extra/jade 1.2.1-10
extra/openjade 1.3.2-4
extra/docbook-utils 0.6.14-6
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Sunday, 19 June 2016, 19:32 GMT
Reason for closing:  Fixed
Comment by Andreas Radke (AndyRTR) - Sunday, 19 June 2016, 07:49 GMT
Afair the current docbook-utils version did not built with our jade pkg. And I always prefer to use an opensource alternative.

Why should we use jade?
Comment by Rafael Fontenelle (josephg) - Sunday, 19 June 2016, 12:53 GMT
My request is just because of the replacement flag in jade's PKGBUILD.
If docbook-utils is installed, openjade is also installed. On every system update, pacman will ask to replace openjade with jade, as jade's PKGBUILD is set with "replaces=(openjade)". If N, it won't replace and won't update. If Y, I have to uninstall docbook-utils to replace openjade. But I need docbook-utils, so I end up resintalling it after the system update.

If docbook-utils can't be built with jade, then IHMO jade should not replace openjade.
Comment by Rafael Fontenelle (josephg) - Sunday, 19 June 2016, 13:51 GMT
Plus problem: fwupd won't build without jade and docbook-utils, as fails in the absence of /usr/bin/nsgmls (provided by jade) and also requires docbook-utils in compilation time. I know fwupd is in AUR, but it is an example of software that requires both.
Comment by Andreas Radke (AndyRTR) - Sunday, 19 June 2016, 17:30 GMT
It should be fine when jade conflicts with openjade. Openjade provides "jade" and should be prefered in any way. Going to conflicts=(openjade) instead of replaces to the jade PKGBUILD.

Loading...