Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#49723 - [qt5] plasmashell crashes everytime I login to KDE

Attached to Project: Arch Linux
Opened by Eric (eric2) - Wednesday, 15 June 2016, 17:32 GMT
Last edited by Antonio Rojas (arojas) - Monday, 20 June 2016, 21:06 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Antonio Rojas (arojas)
Felix Yan (felixonmars)
Architecture i686
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
Since the latest upgrade (plasma-workspace 5.6.5.1-1 and Qt 5.6.1-2 and many other packages) plasmashell crashes everytime I login to KDE. The background will stay black (no wallpaper) and no panel.

Additional info:
This happens since the latest upgrade to plasma 5.6.5.1-1 and Qt 5.6.1-2.
This happens on a newly created home directory with no config files of a previous version.
Some postings on the forum:
https://bbs.archlinux.org/viewtopic.php?pid=1634710#p1634710


Steps to reproduce:
Login to KDE.
This task depends upon

Closed by  Antonio Rojas (arojas)
Monday, 20 June 2016, 21:06 GMT
Reason for closing:  Fixed
Additional comments about closing:  qt5-declarative 5.7.0-2
Comment by Antonio Rojas (arojas) - Wednesday, 15 June 2016, 18:53 GMT
errors? logs? backtrace?
Comment by Sebastian Ziebarth (voeck) - Thursday, 16 June 2016, 13:06 GMT
I can confirm this but only in my VM (using qemu+KVM with QXL graphics), everywhere else it's fine. Simply downgrading all qt5 packages to most recent 5.6.0 revisions solved the problem for me. In the logs I could not see anything useful at all at the first glance. If needed I can try to get some backtraces but not before the weekend.
Comment by Antonio Rojas (arojas) - Thursday, 16 June 2016, 13:14 GMT
Yes, backtraces are always needed when reporting crashes
Comment by Eric (eric2) - Thursday, 16 June 2016, 15:09 GMT
Someone on the forum mentioned that (s)he has this problem only on a 32bit system, the other system (64bit) worked fine. My system is also 32bit.

I've attached a trace copied from systemd's journal.
I don't know if it is useful since the packages were not compiled with debugging turned on.

The output on the console when I started plasmashell manually:

ATTENTION: default value of option vblank_mode overridden by environment.
kscreen: starting external backend launcher for ""
org.kde.plasma: unversioned plugin detected, may result in instability
org.kde.plasma: unversioned plugin detected, may result in instability
org.kde.plasma: unversioned plugin detected, may result in instability
org.kde.plasma: unversioned plugin detected, may result in instability
org.kde.plasma: unversioned plugin detected, may result in instability
org.kde.plasma: unversioned plugin detected, may result in instability
org.kde.plasma: unversioned plugin detected, may result in instability
Could not resolve property : radialGradient4857
Could not resolve property : radialGradient4857
Could not resolve property : radialGradient4857
Could not resolve property : radialGradient4857
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
Segmentation fault (core dumped)
Comment by Sebastian Ziebarth (voeck) - Thursday, 16 June 2016, 15:22 GMT
32bit could be related. The VM is the only 32bit system I have around here.
Comment by Antonio Rojas (arojas) - Monday, 20 June 2016, 19:05 GMT
Can someone please test with Qt 5.7 from testing?
Comment by Sebastian Ziebarth (voeck) - Monday, 20 June 2016, 19:33 GMT
I have just upgraded qt5 from testing but it is still crashing. I have attached what I could get from gdb but of course there are no debugging symbols. Maybe it is useful anyhow. If I find time I will build qt with debugging info tomorrow and try again.
   trace.txt (10.9 KiB)
Comment by Antonio Rojas (arojas) - Monday, 20 June 2016, 19:46 GMT Comment by Sebastian Ziebarth (voeck) - Monday, 20 June 2016, 19:59 GMT
Unfortunately no change.
Comment by Antonio Rojas (arojas) - Monday, 20 June 2016, 20:29 GMT Comment by Sebastian Ziebarth (voeck) - Monday, 20 June 2016, 20:48 GMT
No, still no chance.
Comment by Sebastian Ziebarth (voeck) - Monday, 20 June 2016, 21:01 GMT
Sorry, I must correct myself. The last version seems to have fixed it after a full reboot.
Comment by Antonio Rojas (arojas) - Monday, 20 June 2016, 21:05 GMT
Great, thanks for testing

Loading...