Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#49700 - [texmacs] texmacs hangs at launch with 'Booting' or ''GNU TeXmacs 1.99.4' displayed in its statusbar

Attached to Project: Arch Linux
Opened by Chris Koresko (ckoresko) - Monday, 13 June 2016, 17:26 GMT
Last edited by Doug Newgard (Scimmia) - Monday, 13 June 2016, 23:25 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

This program was working on my x86-64 system until a week or two ago, but now it hangs on boot. The application appears to start normally until after the main window is displayed. It usually shows the word 'Booting' in the statusbar on the lower right of the window.

I suspected that it might have been broken by a library upgrade, so I rebuilt it from the PKGBUILD. But the rebuilt version has the same problem.

I tried rolling back to the previous version of TeXmacs (texmacs-1.99.4-1) but it has the same problem.

I tried moving the .TeXmacs directory to .TeXmacs.backup and restarting. The TeXmacs main window opened with the 'Welcome to GNU TeXmacs' document loaded, but the controls are unresponsive.

OS is Arch x86_64 with all updates as of 13jun2016, running on the LTS kernel. Desktop environment is MATE with cairo-dock and compiz (AUR).


Additional info:
* texmacs-1.99.4-2-x86_64.pkg.tar.xz -or- texmacs-1.99.4-1-x86_64.pkg.tar.xz

$ texmacs -V -d
Installing internal plug-ins...
Opening display...
Starting server...
TeXmacs] debug-std, Evaluating /usr/share/TeXmacs/progs/init-texmacs.scm...
Creating 'no name' buffer...
TeXmacs] debug-convert, Loading dictionary corktounicode
TeXmacs] debug-convert, Loading dictionary cork-unicode-oneway
TeXmacs] debug-convert, Loading dictionary tmuniversaltounicode
TeXmacs] debug-convert, Loading dictionary symbol-unicode-oneway
TeXmacs] debug-convert, Loading dictionary symbol-unicode-math
TeXmacs] TeXmacs] Loading hyphen.us
TeXmacs] debug-convert, Loading dictionary corktounicode
TeXmacs] debug-convert, Loading dictionary unicode-cork-oneway
TeXmacs] debug-convert, Loading dictionary tmuniversaltounicode
TeXmacs] debug-convert, Loading dictionary unicode-symbol-oneway
TeXmacs] debug-fonts, Loading ecrm10 at 600 dpi
TeXmacs] debug-fonts, Try tfm ecrm10.tfm
TeXmacs] With linked TrueType support
TeXmacs] debug-fonts, Loading True Type font ecrm10
TeXmacs] debug-fonts, Loading larm.enc
TeXmacs] debug-fonts, Loading grmn.enc
TeXmacs] debug-fonts, Loading ecss10 at 600 dpi
TeXmacs] debug-fonts, Try tfm ecss10.tfm
TeXmacs] debug-fonts, Loading True Type font ecss10
TeXmacs] debug-std, Redefined color dark slate
TeXmacs] debug-std, #2F4F4F replaced by #483D8B
TeXmacs] debug-std, Redefined color light slate
TeXmacs] debug-std, #778899 replaced by #8470FF
TeXmacs] debug-std, Redefined color light goldenrod
TeXmacs] debug-std, #FAFAD2 replaced by #EEDD82
TeXmacs] debug-std, Evaluating /usr/share/TeXmacs/progs/init-buffer.scm...
Starting event loop...

Steps to reproduce: Launch TeXmacs. 100% reproducible.

This task depends upon

Closed by  Doug Newgard (Scimmia)
Monday, 13 June 2016, 23:25 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#49703 
Comment by Chris Koresko (ckoresko) - Monday, 13 June 2016, 19:39 GMT
Noticed that maxima wouldn't start. A bit of searching revealed that maxima depends on having the exact version of SBCL (lisp interpreter).

Downloaded the maxima PKGBUILD and attempted to build, but it failed because the icon file was missing. Found that and copied it into the root of the build directory (/home/koresko/build/maxima) and it built. Installed it, and maxima worked. Tried running TeXmacs, and that worked. Cool.

I had no idea that TeXmacs actually depends on having maxima work, if maxima is installed.

So the real bug is apparently that maxima needs to be rebuilt to be compatible with the current version of SBCL.

Loading...