Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#49636 - Linux 4.6.1-2-ARCH fails to mount F2FS partition during boot

Attached to Project: Arch Linux
Opened by Isabell Cowan (Izzette) - Thursday, 09 June 2016, 17:47 GMT
Last edited by Dave Reisner (falconindy) - Thursday, 09 June 2016, 19:34 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
After installing the latest 4.6.1-2-ARCH kernel, I was unable to complete the boot sequence because I failed to mount my real root on F2FS. The error message occurred during mounting "F2FS-fs (sda3): Cannot load crc32 driver". The crc32c_intel driver was loaded into the kernel at the time. However, I can mount an F2FS partition on another machine running Linux 4.6.1-2-ARCH running on EXT4 root after booting normally. Continues to work fine with Linux 4.5.4-1-ARCH (which I have downgraded to).

Additional info:
* Linux 4.6.1-2
* I have attached my mkinitcpio.conf

Steps to reproduce:
Mount an F2FS partition using the initramfs.
This task depends upon

Closed by  Dave Reisner (falconindy)
Thursday, 09 June 2016, 19:34 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#49380 
Comment by Samantha McVey (samcv) - Thursday, 09 June 2016, 18:02 GMT
I have also had tons problems with f2fs under the kernel 4.6 as well... I was forced to upgrade to 4.7RC2 to get my f2fs messages to go away. I may have been getting a different specific bug than yours but there are MANY f2fs fixes are in 4.7. You can either try this AUR package:
https://aur.archlinux.org/packages/linux-mainline/
Or the package is also available rebuilt on an *unofficial* repository, listed here:
https://wiki.archlinux.org/index.php/unofficial_user_repositories#miffe
Please let me know if 4.7RC2 fixes your issues!
Comment by Isabell Cowan (Izzette) - Thursday, 09 June 2016, 19:13 GMT
No luck so far with linux-mainline. Trying linux-git.
Comment by Samantha McVey (samcv) - Thursday, 09 June 2016, 19:19 GMT
It looks like this is a duplicate of bug https://bugs.archlinux.org/task/49380
Can you repost in the comments on this other bug? Thanks. Recommending this bug be closed due to duplicate.

Loading...