Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#49634 - [glfw-x11] Improper tagging in .pc file

Attached to Project: Community Packages
Opened by Jeremiah O'Neil (Jerr) - Thursday, 09 June 2016, 15:20 GMT
Last edited by Doug Newgard (Scimmia) - Friday, 10 June 2016, 21:26 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

glfw3.pc, line 10: 'xi' and 'gl' are missing from Requires.private.
Consequently, `pkg-config --static --libs glfw3` is insufficient for static linkage.


This task depends upon

Closed by  Doug Newgard (Scimmia)
Friday, 10 June 2016, 21:26 GMT
Reason for closing:  Not a bug
Additional comments about closing:  You aren't going to be able to statically link this when there's no static lib anyway.
Comment by Doug Newgard (Scimmia) - Friday, 10 June 2016, 03:54 GMT
There are no static libs in the package.
Comment by Jeremiah O'Neil (Jerr) - Friday, 10 June 2016, 18:25 GMT
aha... Regardless, xi and gl should be listed as requirements. I don't know why, but on my system the shared libglfw doesn't take care of those links; I can't compile unless I explicitly link the libraries which glfw requires. So, I have to use `pkg-config --static --libs glfw3` even though glfw is shared, and -lxi -lGL as well due this bug.
Comment by Doug Newgard (Scimmia) - Friday, 10 June 2016, 19:12 GMT
I'm pretty sure this isn't a bug, libglfw3 isn't linked to libXi or libGL, even recursively. More likely that something is screwy in your build.

Loading...