Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#49594 - [systemd] systemd reporting version "229" on boot on version 230

Attached to Project: Arch Linux
Opened by Ruben Kelevra (RubenKelevra) - Monday, 06 June 2016, 13:09 GMT
Last edited by Doug Newgard (Scimmia) - Monday, 06 June 2016, 13:20 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
on boot "starting version 229" is printed, but the installed version is version 230.2

Additional info:
* package version(s)
230-3

Steps to reproduce:
boot the system
This task depends upon

Closed by  Doug Newgard (Scimmia)
Monday, 06 June 2016, 13:20 GMT
Reason for closing:  Not a bug
Comment by xduugu (xduugu) - Monday, 06 June 2016, 13:15 GMT
You have to recreate your initramfs to include the new systemd binaries. Run

$ mkinitcpio -p linux

for the kernel provided by the linux package.
Comment by Doug Newgard (Scimmia) - Monday, 06 June 2016, 13:20 GMT
It's not systemd reporting this, it's udev. As xduugu pointed out, it's still at that version in your initramfs.

Loading...