Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#49519 - [audacious] Hangs up after start

Attached to Project: Arch Linux
Opened by Dmytro Bagrii (dimich) - Tuesday, 31 May 2016, 07:47 GMT
Last edited by Eli Schwartz (eschwartz) - Monday, 25 September 2017, 23:03 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Audacious 3.7.2-2 hangs up immediately after start. Process exists and can be killed with SIGKILL only. Audacious 3.7.2-1 works fine.
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Monday, 25 September 2017, 23:03 GMT
Reason for closing:  Fixed
Additional comments about closing:  This works with the current package audacious 3.9-1
Comment by Dmytro Bagrii (dimich) - Tuesday, 31 May 2016, 08:33 GMT
UPD: I built audacious with PKGBUILD version 3.7.2-2 by myself. In this case it starts very slowly and writes messages like this:

ERROR neon.cc:539 [open_request]: <0x7fcf1c023b20> Could not open URL: 6 (0)
ERROR neon.cc:542 [open_request]: <0x7fcf1c023b20> neon error string: Could not connect to server: Connection timed out

Looks like it tries to get information about some internet radio stations in my playlist on startup, and they are unavailable. So i guess it's not a bug of Arch package but issue of audacious application itself. I have no idea why makedepends affects the application behaviour.
Comment by Evangelos Foutras (foutrelis) - Monday, 25 September 2017, 15:59 GMT
Is this still an issue for you?
Comment by Dmytro Bagrii (dimich) - Monday, 25 September 2017, 20:36 GMT
Now it works fine for me. Sorry i forgot to update the issue status. The ticket can be closed i guess.

Loading...